Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Smart Update problem
  • From: mikus@xxxxxxx (Mikus Grinbergs)
  • Date: Tue, 18 Jul 2006 15:28:03 -0500
  • Message-id: <TRUvElW2vrWC092yn@xxxxxxx>
On Wed, 19 Jul 2006 00:57:06 +1000 Basil Chupin <blchupin@xxxxxxxxxx> wrote:
> Rahul Raj wrote:
> > Hi All,
> >
> > I tried to update suse 10.1 with yast and failed miserably.
> >
> > I Installed smart, and gave a system update. Patches were downloaded for
> > about 4 hours and in the end it popped a message saying some packages
> > couldn't be retrieved(lots of packages were downloaded).
> >
> > Nothing happened after that, how do I make sure all the patches were
> > installed properly? No messages or logs were given. What happened to the
> > downloaded patches?
> >
> > Is there any proper documentation for Smart?
> >
> > Rahul
>
> I had the same hassle at the start. Seemed that there were some packages
> which could not be downloaded from the selected channel(s) and so while
> the packages were downloaded they were not installed.
>
> Start up the Smart Package Manager (Start/System/Configuration ) and
> Refresh All the Channels and you will (probably) find that smart will
> now go away and finish downloading the outstanding packages. Main thing
> is not to panic. Just wait and smart will eventually complete the job -
> possibly after the next reboot.
>
> Re documentation, go to the smart site and there you will find a FAQ
> which explains a lot.
>
> While you are there get yourself onto the mailing list of the smart
> forum. Ask questions there and you get almost instant response (like I
> am having over the past hour or so :-) ).

I've been told that smart considers the command you gave it to be
a single "transaction". And smart implements the philosophy: 'If
part of a "transaction" cannot be fulfilled, then none of that
"transaction" ought to be fulfilled'. Smart treated your "system
update" as a single "transaction" -- and since there were some
packages it could not retrieve, it decided to not proceed with
installing those packages it *did* retireve.

When a package manager does not complete an upgrade I wanted, my
procedures for "continuing anyway" are:

- If using the command line, I get the package manager to list
out the names of the packages it wanted to process. Then I
manually issue a command (e.g., 'smart install') into which I
have pasted some names from the list (omitting those that
had trouble). Proceeding thus by bits and pieces, I usually
manage to install those packages which were downloaded o.k.,
and have no non-downloaded dependencies. [What I've done
is to break the original single "transaction" into several
smaller "transactions", and requested that each of these
smaller "transactions" be installed individually.]

- If using 'smart --gui' (my normal mode) I ask to view with
'hide unmarked'. I then go through the resulting list,
__unmarking__ those packages which failed to download (if
you don't remember, the 'Log window' would have told you).
Then I click on 'Apply' again, and see what happens (may
need to do these steps more than once). Eventually, those
packages that can be installed will be. [What I've done is
to "parse" the original "transaction", removing items until
what is left *can* be installed.]

At the end of the above procedure(s), you will be left with some
packages still not installed. As suggggested by Basil, you may
later (when problems at the repositories have hopefully been
corrected) try again, starting with refreshing the channels.


mikus


--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
References