Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Router with two internal NIC's
  • From: James Knott <james.knott@xxxxxxxxxx>
  • Date: Sun, 30 Jul 2006 10:46:12 -0400
  • Message-id: <44CCC634.4070700@xxxxxxxxxx>
Nikodemus Karlsson wrote:
>
> 30 jul 2006 kl. 03.09 skrev James Knott:
>
>> Nikodemus Karlsson wrote:
>>> Hi,
>>> I'm trying to set up a router with two internal NIC's and one NIC
>>> connected to Internet. I have enabled DHCP support for the internal net.
>>> On the SuSE 10.1 box, I get an IP from my isp, and I have connection to
>>> the Internet. On my client machines, I get IP's from the SuSE box, but I
>>> have no connection to either the Internet or the SuSE box. When I
>>> disable one NIC, I have connections. It seems like the problems occure
>>> when there are more than one internal NIC.
>>>
>>> Any one who knows the solution?
>>
>> I have a 3 port firewall/router running SUSE 10 here and it works fine.
>> You say you're running DHCP. I assume you've got the two local
>> networks on different subnets. If so, each subnet will need it's own
>> unique default route.
>
> How do I set the default route for the subnets? Can I do it in YaST?

I normally use static addresses on my local lan, though DHCP is
occasionally available. However, I don't run the dhcp server on my
firewall. When I want one, I run it on another system.

--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >