Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [opensuse] problem with lvcreate and udev
  • From: Stefan Schmidt <s.schmidt@xxxxxxxxxxxx>
  • Date: Tue, 11 Jul 2006 12:07:53 +0200
  • Message-id: <200607111207.54293.s.schmidt@xxxxxxxxxxxx>
Hello Peter,

On Wednesday 05 July 2006 11:21, Peter Münster wrote:
> Hello,
> when trying to create a snapshot with
>
> lvcreate -L 700M -s -n snap-usr -p r /dev/system/usr
>
> I get very often the following error:
>
> LV system/snap-usr in use: not deactivating
> Couldn't deactivate new snapshot.
>
>
> After googling, it seems to be a race condition when using udev
> with lvm. But I didn't really find a solution, especially for
> SuSE-10.1. Does anybody know more about this problem and the right
> way to solve this?

I saw the same behaviour with earlier versions of SUSE Linux (tested
9.3 with this problem), and made a bugzilla bug: 96808
I lost track with the 10.0, as I do not run a system with either
version 10.0 or 10.1 with LVM snapshot needs.

On 9.3 I could circumvent the problem by creating a snapshot of size
512M and lvresize it afterwards to the desired size. Yes, sometimes
it is still not createable, but repeated trying succeeds.

Addition:
I just tried to create a snapshot of my /home LV on 10.1, and it
blocks -> reboot :(

Greetings,

Stefan
--
Stefan Schmidt
Network Manager
International University Bremen

From RFC1925:
"Good, fast and cheap: choose any two (you can't have all three)!"

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-help@xxxxxxxxxxxx

< Previous Next >
References