Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] Changing hardware IRQ's
  • From: Sunny <sloncho@xxxxxxxxx>
  • Date: Mon, 1 May 2006 09:08:33 -0500
  • Message-id: <e7eeb230605010708q7d66ce04v17e37095d86dd3eb@xxxxxxxxxxxxxx>
On 4/30/06, Carl Hartung <suselinux@xxxxxxxxxxxxx> wrote:
On Sunday 30 April 2006 14:16, Sunny wrote:
> Ok, lets say I have "proven" problem. Actually the problem is with the
> mobo and the chipset (it is SiS, and there are some problems), but I
> guess if I can move the sound on another irq, it'll work ... so,
> what's the way to change the assigned irq by the driver/kernel?

Hi Sunny,

Would you care to share the mainboard model and chipset numbers (and revision,
if appropriate?) I apologize in advance if you've posted this already, but I
sometimes seem to have a very 'twitchy' delete key finger! ;-)

regards,

Carl


Hi Carl,
the machine is Compaq Presario SR1710NR, Sempron 3400+, Asus mobo with
SiS chipset
ASUS A8AE-LE. Here is a link to mobo specs on hp site:
<http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&cc=us&dlc=en&product=1817035&docname=c00496280>

So, the problem is that the APIC kernel support for this mb is kind of
shaky. Most of the devices (incl. sound, network, etc.) share the same
IRQ. Even if I disable the onboard sound and put another one (tried
with PCI and USB), it hooks up them to tre same IRQ.

And I can not use the mike - it breaks after 2-3 sec of working, I
tried skype, and other recording programs. I tried both 64 and 32 bit
SuSE 10, Knoppix 32 bit. It is always the same.

I know from the kernel lists that there is a problem with the APIC
support for some SiS mobo's, so I hope that if I can set the IRQ for
the sound to something else, it may work.

Cheers
Sunny


--
Svetoslav Milenov (Sunny)

Windows is a 32-bit extension to a 16-bit graphical shell for an 8-bit
operating system originally coded for a 4-bit microprocessor by a
2-bit company that can't stand 1 bit of competition.
< Previous Next >
Follow Ups