Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] Problem with Tomcat 5.0
  • From: "George Stoianov" <gstoyanoff@xxxxxxxxx>
  • Date: Fri, 19 May 2006 08:26:37 -0400
  • Message-id: <e0b842610605190526i298a4df9t7a85cd86a9facd44@xxxxxxxxxxxxxx>
On 5/19/06, Gaël Lams <lamsgael@xxxxxxxxx> wrote:
Hi,

> I am having a problem with Tomcat on SuSE 10.0 namely it will not start:
>
> WARNING: Unexpected exception resolving reference
> java.io.FileNotFoundException:
> /usr/share/tomcat5/conf/tomcat-users.xml.new (Permission denied)
> ...
> I have not made any changes to that file and the permissions on the
> file which the error is complaining about are set to:
> I have 2 servers that have the same problem, is anyone else
> experiencing this??? It used to work maybe a few days ago and I have
> made some updates since then now it does not.

I never used the tomcat rpm given by Suse so I may be wrong but when
you performed a update, yast executed different scripts: probably one
of these scripts modified your permissions/configuration (suse's
documentation often remembers it).
You have two possibilities
- find that script and modifies it so that it does not happen again
- if you decide to use Tomcat on a production server, my advice would
be not to use the one provided by Suse but to download it from
tomcat.apache.org and configure it the way you want. I've nothing
against the tomcat's installationm made by Suse but this way you will
1) really understand how it's configured and 2) keep control of your
installation. It's for instance the same reason why, for my zope
instances, I don't use the python provided by the distribution.
Obviously, it's just a personal preference.

Should you decide to follow my second suggestion, I can send you a
step-by-step how-to, it's not that difficult.

Yes, please send me the step by step instructions. I think what
happened here is I installed the rpm from SuSE, which has always
worked just fine (9.1, 9.2, 10.0) for me even though lagging behind in
versions from the official stable on jakarta.apache.com. I am not sure
but I think an update was available from suse for something security
related and I applied it on both my machines and now I cannot start
because the user database (which is a text file) cannot be loaded,
stack trace is pasted above. What I do not understand is the file name
it refers to as that is no where to be found by default unless it is a
temp file created at start up and cached somehow it is a complete
puzzle to me...

I am (I think) pretty familiar with configuring Tomcat as I have used
for a few years now, but I am not very familiar with editing the start
up scripts in /etc/init.d/tomcat5, for example and how that relates to
YaST and run levels so I am going to have a problem figuring that out.
Do you have any hints on that???

I read the script tomcat5 which specifically sets the file permissions
to tomcat:tomcat which I did but to no avail as I get the same error
message. I am thinking of uninstalling the rpm and reinstalling from
the DVD to see what happens, will post my findings.

Please forward me your how to and if you have something similiar for
Zope 3 I would greatly appreciated as SuSE 10.0 has only 2 I think and
3 seems to be a change in architecture which I want to have a look at.

Thanks very much.
Best regards
George


Regards,

Gaël


< Previous Next >