Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
10;1 Software updater Not working
  • From: "Doug Currey" <doug@xxxxxxxxxxxxxxxxx>
  • Date: Mon, 22 May 2006 12:25:42 -0400
  • Message-id: <20060522161647.M43589@xxxxxxxxxxxxxxxxx>
I am showing 6 updates in the software updater. Actually 3 everything repeats
twice.

After clicking Update It goes to resolving Dependance. Then a several seconds
later I get an error "Dependency Resolution Failed"

If I click on just 1 package to update I get a more detailed message

---------------------------------------------------------------------------
Novell.Zenworks.Zmd.Public.ZenException: Failed to lookup resolvable with
id '591173'

Server stack trace:
in <0x00178>
Novell.Zenworks.Zmd.Packaging.RedCarpetBackend SqlTransaction:GetResult ()
in <0x00081>
Novell.Zenworks.Zmd.Packaging.RedCarpetBackend:ResolveDependencies
(Novell.Zenworks.Zmd.Packaging.IResolvable[] installs,
Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades,
Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x00023> Novell.Zenworks.Zmd.Packaging.PackageManager:Resolve
(Novell.Zenworks.Zmd.Packaging.IResolvable[] installs,
Novell.Zenworks.Zmd.Packaging.IResolvable[] upgrades,
Novell.Zenworks.Zmd.Packaging.IResolvable[] removals)
in <0x00038>
Novell.Zenworks.Zmd.Packaging.RemotePackageManager:ResolveDependencies
(Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] installs,
Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] upgrades,
Novell.Zenworks.Zmd.Packaging.Public.ResolvableInfo[] removals)
in <0x00000> <unknown method>
in (wrapper managed-to-native)
System.Runtime.Remoting.RemotingServices:InternalExecute
(System.Reflection.MethodBase,object,object[],object[]&)
in <0x00188>
System.Runtime.Remoting.RemotingServices:InternalExecuteMessage
(System.MarshalByRefObject target, IMethodCallMessage reqMsg)

Exception rethrown at [0]:

in <0x006dc> System.Runtime.Remoting.Proxies.RealProxy:PrivateInvoke
(System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg,
System.Exception exc, System.Object[] out_args)

-----------------------------------------------------

This did work the couple days correctly.

What have I done?????

< Previous Next >