Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] Can't Boot Init 5 with Suse 10 OSS
  • From: James Wright <jwright01@xxxxxxx>
  • Date: Tue, 23 May 2006 07:33:21 -0400
  • Message-id: <4472F301.2050009@xxxxxxx>
James Wright wrote:
Well this seems to be just a video issue. I can do a normal (not failsafe) boot to init 3, as long as 'vga=normal' is set in the grub boot parameters. The graphics card is an Nvidia TNT2/TNT2 Pro. I downloaded the Nvidia driver installation script that supports this card, NVIDIA-Linux-x86-1.0-6629-pkg1.run. When I run the script I get the rivafb warning, then the install continues. It reached 100%, then goes to a screen that says it failed to build the driver. Below is a snipped version of the log:
Ok, the 6629 wasn't the last Nvidia driver to support the TNT2/TNT2 Pro card. I downloaded the 7167 driver and that installed fine. The computer still isn't booting to init 5 or with the boot parameter 'vga' set to anything but 'normal'. Sax2 still will not load. Here is what I have done:

Install 7167 driver.

ran 'switch2nvidia'

did a: # modprobe nvidia

ran makedevices.sh

tried init 5, which then said ready, but didn't go further. I hit CTRL-C and got dropped to the CLI. Tried startx, and the computer entirely froze.

Added makedevices.sh to boot.local.

Reboot.

No go. Still freezes. Sax2 -m 0=nvidia reports that no screen is found. xorgcfg reports the same. I have been watching the 'Nvidia / AV Out Not Center' thread as well as http://www.linuxquestions.org/questions/showthread.php?t=380061. I checked out the threads in the Nvidia forums, others have similar problems, but not real solution. I should mention that the nvidia module is not getting loaded into the kernel, I seem to have to do it by hand each time. I'm still plugging away at this, and if I find a solution I will post it. I welcome any suggestions. Windows XP and Server 2003 have not problems with this card, so I assume the card is fine.

- James W.




< Previous Next >
Follow Ups