Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] DMA Nightlmare on SuSE 10.x Revisited
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Sun, 28 May 2006 20:46:37 +0200 (CEST)
  • Message-id: <Pine.LNX.4.61.0605282039120.10059@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


The Monday 2006-05-29 at 00:35 +1000, Basil Chupin wrote:

> > DEVICES_FORCE_IDE_DMA="/dev/hda:-c1:-m16:-u1 /dev/hdb:-c1:-m16:-u1
> > /dev/hdd:-c1:-m16:-u1 /dev/hdc:on"
>
> Yeah, but we are talking here about v10.1 which is an animal of a different
> kind...

True.

>
> OK, this is what I tried and the results.
>
> Firstly, the comment that the params you show above are not the same as you
> gave in an earlier response so I'll ignore the above and use what you gave

Well, my first one I created for you, taking my real line and leaving
only the parameters I thought you needed. Posibly I misstyped something.
The second one is the one that I'm actually using.

> On both occasions the above statements in /ide were ALTERED to read:
>
> ..._DMA=""
>

Oh, my! :-(


> I then used the approach which Silviu provided which was to use
> /etc/init.d/boot.local.

Yes, that one must work. Time ago, I created my own
"/etc/init.d/boot.localhw" service script instead. I'm not using it now,
but I might use it again when I install 10.1. Basicly, I run hdparm.



> > Use a text editor to directly edit the file.
>
> Doesn't appear that using anything will stop from something in SuSE amending
> ../ide to whatever it is "programmed" to do (against your will in fact).

It must be something in hald/devfs/subfs/whatever.

>
> All these things above I found after much time in
> typing/rebooting/typing/rebooting/typing/ad finitum :-) . I'll never be
> same...

You sure have saved a lot of time for many of us ;-)

- --
Cheers,
Carlos Robinson

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFEefAhtTMYHG2NR9URAo2JAJwI3F3TyWtm4TONRifjAUnBVHgQwgCbBxxQ
u4pITTFipT4u6kKHq51pLvY=
=mAQ9
-----END PGP SIGNATURE-----


< Previous Next >