Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
installer can't see partition table
  • From: Steve Miller <doctor_clyde@xxxxxxxxx>
  • Date: Sun, 28 May 2006 17:01:43 -0700 (PDT)
  • Message-id: <20060529000143.98768.qmail@xxxxxxxxxxxxxxxxxxxxxxx>
Greetings,

I recently downloaded and burned CD's for OpenSuSE
10.1 in the hopes of installing it on my computer at
home. Currently, it runs SuSE 8.2 on an ext3 file
system.

The installer starts up as it should and seems to have
no problems until after it asks me what I wish to do.
I have answered all variants of the following: update
an existing installation vs. install new and with or
without packages on aditional media (which I presume
to mean the add-on CD from the OpenSuSE site). I have
also tried initially selecting "local APIC disabled".
I have, howver, NOT yet tried installing with "APCI
disabled" since my mothrboard supports it. (And won't
get to it for a few hours, so I might as well ask
while I'm on the sidelines anyway...)

In every case, when I select "show all psrtituions", I
get a list of ONLY the primary partitions of my two
hard drives, and in no case did it seem remotely aware
of the file systems in use. On one occasion, I decided
to see what would happen if I told the installer to
continue anyway.

This got me the following message, which no amount of
googling shed any light on. "No installed system that
can be upgraded with this product was found on the
selected partition."

Here is the partition table (from sdisk -l) for the
system disk. The other disk, /dev/hdc, is data-only.

Disk /dev/hda: 1027 cylinders, 255 heads, 63
sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024
bytes, counting from 0

Device Boot Start End #cyls #blocks Id
System
/dev/hda1 * 0+ 1 2- 16033+ 83
Linux
/dev/hda2 2 894 893 7173022+ 83
Linux
/dev/hda3 895 927 33 265072+ 82
Linux swap
/dev/hda4 928 1026 99 795217+ f
Win95 Ext'd (LBA)
/dev/hda5 928+ 960 33- 265041 82
Linux swap
/dev/hda6 961+ 993 33- 265041 82
Linux swap
/dev/hda7 994+ 1026 33- 265041 82
Linux swap

/dev/hda1 is mounted as /boot and /dev/hda1 as / .

Is OpenSuSE purposely written so as not to recognize
its purchased cousin? Is there a way to get the
installer to at least "see" my partitions, as SuSE
installers have on sveral past occasions? Am I missing
something glaringly obvious?

I would greatly appraciate any assistance with this,
even if only RTFM -- so long as you also "tell me
where to go" in the literal sense!

TIA, and Cheers!

Steve

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

< Previous Next >