Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] New 10.1 x86_64 install has NO usb connectivity
  • From: Patrick Shanahan <ptilopteri@xxxxxxxxx>
  • Date: Wed, 31 May 2006 16:33:00 -0400
  • Message-id: <20060531203300.GI20492@xxxxxxxxxxxxxxx>
* Carl Hartung <suselinux@xxxxxxxxxxxxx> [05-30-06 10:56]:
> I believe you can make these changes in SUSE using the YaST module
> "/etc/sysconfig Editor".
> System > Kernel > INITRD_MODULES


knoppix 5.0 live x86_64 dvd:

usblp 14720 0
usbhid 47584 0
usb_storage 70848 1
usbcore 111492 7 usblp,usbhid,usb_storage,ohci_hcd,uhci_hcd,ehci_hcd


kubunto 6.06 live cd:

usblp 13056 0
usb_storage 74176 4
usbcore 129668 6 usblp,quickcam,usb_storage,ehci_hcd,ohci_hcd
scsi_mod 138984 4 sg,usb_storage,sd_mod,libata


I added below to INITRD_MODULES
usbcore usb_storage usblp scsi_mod

result:
usblp 31104 0
usb_storage 97728 0
usbcore 150312 5 usblp,usb_storage,ohci_hcd,ehci_hcd
scsi_mod 163888 6 st,sr_mod,usb_storage,sg,libata,sd_mod
ide_core 165764 6
usb_storage,ide_cd,ide_floppy,pdc202xx_old,amd74xx,ide_disk

I now have usb printer access, but usb cardreader and external hard
drive do not show. Hot-plugging does not seem to make any impact
either. /proc/bus/sub/ is still empty.


Am very close to a complete reinstall (saving the new home to a remote
partition and then mv'ing back pertinent files, of course).

One other point: Booting the install dvd will not complete the usb
search if I leave my usb Epson 2400 scanner connected.
--
Patrick Shanahan Registered Linux User #207535
http://wahoo.no-ip.org @ http://counter.li.org
HOG # US1244711 Photo Album: http://wahoo.no-ip.org/gallery2

< Previous Next >