Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [opensuse] packagemanagement in 10.1
  • From: Eberhard Moenkeberg <emoenke@xxxxxxx>
  • Date: Sat, 27 May 2006 18:58:08 +0200 (CEST)
  • Message-id: <Pine.LNX.4.61.0605271854360.8922@xxxxxxxxxxxxxx>
Hi,

On Sat, 27 May 2006 andreas.hanke@xxxxxxxxxxxxxx wrote:

- apt-rpm: while some people report bad experiences with it (corrupt RPM
database), I personally never had issues with it (but I've been using
smart since some time now) and it seems that it's being actively
maintained and developed again, and even supports RPM-MD (yum)
repositories in its latest versions (though that's not the one shipped
on the 10.1 FTP tree)

OK, but then it should be made very clear that this one (apt) is not the one whose resolver engine was designed to work with the repositories provided for SUSE Linux. Especially, it should be made very clear that it is not biarch safe, which YaST/zypp is (or at least, should be).

There is a bug 176739 and I blame using non-YaST/zypp package managers for it.

You better should blame the non-matching package release numbers for glibc-devel (i686 has a higher number).

Some examples of people experiencing this problem (two of them in German, unfortunately):

http://forums.suselinuxsupport.de/index.php?showtopic=37096
http://www.linux-club.de/ftopic60412.html
http://www.linux-club.de/ftopic61119.html

This is not "some examples" - this is all you have.
Your mouth is bigger than your head.

Cheers -e
--
Eberhard Moenkeberg (emoenke@xxxxxxx, em@xxxxxxx)

< Previous Next >
Follow Ups