Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Direct Rendering and XGL at the same time doesn't work
  • From: Francis Giannaros <francisg@xxxxxxxxx>
  • Date: Fri, 12 May 2006 22:17:17 +0100
  • Message-id: <200605122217.17761.francisg@xxxxxxxxx>
I've seen quite a few people with this problem, and I certainly experience it.
Nvidia drivers are successfully installed following the guidance on
http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html

If I run sax2 -r -m 0=nvidia, and add in Option "RenderAccel" "true" into
xorg.conf (under the appropriate nvidia driver section), then when I start an
x session, I do indeed have direct rendering (I check by glxinfo|grep
direct).

Now, if I enable XGL once again following the instructions as they were on
opensuse.org (changing /etc/sysconfig to =Xgl etc etc and then running
SuSEconfig --module xdm), direct rendering is turned off, and there appears
no way to re-enable it.

I delete the Option "RenderAccel" "true", and still no luck; adding it in
doesn't help. If I reconfigure sax, however, with the above sax2 command,
then direct rendering can work fine. But Xgl won't :).

It produces the error that there is no composite extension; an error, I
presume, that would come from Xgl apparently not being loaded but plain Xorg.

I guess a bug report should be filed about this, just first want to see if
anyone else is not experiencing this problem. Would be nice to have full
hardware acceleration and Xgl at the same time, since it'd be smoother. :)

Regards,
Francis Giannaros (apokryphos).

< Previous Next >