Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] nfs and samba -SOLVED
  • From: kanenas@xxxxxxxxxxxxx
  • Date: Sun, 2 Apr 2006 07:39:22 -1000
  • Message-id: <200604020739.22955.kanenas@xxxxxxxxxxxxx>
On Saturday 01 April 2006 13:49, Marlier, Ian wrote:
> > -----Original Message-----
> > From: kanenas@xxxxxxxxxxxxx [mailto:kanenas@xxxxxxxxxxxxx]
> > Sent: Saturday, April 01, 2006 4:45 PM
> > To: suse-linux-e@xxxxxxxx
> > Subject: [SLE] nfs and samba
> >
> > Is there a problem running nfs and samba at the same time in suse
>
> 10.0? I
>
> > recall doing that with no problem a few versions back, but after i
>
> started
>
> > nfs server/client my samba stopped working. nfs client is running
>
> fine.
>
> I've had some trouble, when the same directory is being shared with
> samba and exported with NFS. Not sure if that's the same case that
> you're running into...
>
> The 2.6 kernel/NFS4 changed the way that locking is done by the NFS
> server, and I think that's why the changed behavior from earlier
> versions of SuSE...

Sharing the same directory was not the case. The problem was that Yast (i
don't recall doing that myself but memory is the first thing that goes with
age,right?) had added a domain name suffix (.site) to the server name
in /etc/hosts and i had a simple workgroup setup in samba, so the workgroup
was not being found. Once i removed the .site all worked fine and the
firewall went back up.
Thanks for the directory comment, will keep it in mind.

d.


< Previous Next >
This Thread
References