Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
RE: [SLE] GRUB problems
  • From: "Greg Wallace" <gregwallace@xxxxxxxxxxx>
  • Date: Mon, 3 Apr 2006 11:24:39 -0500
  • Message-id: <!&!AAAAAAAAAAAYAAAAAAAAABYv/fsiAbFHuuseWu7lbHnCgAAAEAAAADCM0pGx0U5PoogYWKU8UYIBAAAAAA==@xxxxxxxxxxx>
On Monday, April 03, 2006 @ 8:34 AM, Mike Cleary wrote:

>I have a machine at home which has SuSE and Windows on separate drives. A
>while back windows died and had to be reinstalled, which of course blew
away
>the MBR. This weekend I booted linux from the dvd and proceeded to
perform
>an update (9.2 to 10). During the upgrade, the GRUB install failed
>(couldn't find stage 1). I tried every combo offered in the way of where
to
>install GRUB, but it failed every time. I usually install it in the MBR of
>/dev/hda1 (windows drive), which may or may not be the best place to put
it.
>Even so, I tried installing it in the boot sector of the root partition,
but
>still no joy. Unfortunately, windows needs to be the default OS to boot on
>this machine, and before having to reinstall windows I had no problem using
>GRUB. Any assistance w/ resolving this issue would be greatly appreciated!



>TIA,



>Mike

>-------------------------------

>Cleary_Mike@xxxxxxx

>-------------------------------

>A wink is as good as a nod to a blind horse.

Stage 1 has to be written to the MBR. Try the following.

1) Boot Linux from the CD.
2) In a shell, enter grub
3) at the prompt, enter --

find /boot/grub/stage1

This should tell you where stage 1 is targeted to be installed
(something like (hd0,1). Your /boot/grub/device.map will tell you what hd
the hdn in this message is referring to; i. e., hda, hdb, etc.). If nothing
has changed since you upgraded to 10, it should still be the hard drive of
the Windows machine (that's the boot drive on your computer, based on what
you have said).

4) Then do

root (hdn1,n2) <- n1 and n2 are the numbers that came out of the above
find command; i. e., just enter that same string in the root command

5) Finally, do

setup (hdn1) <- n1 being the number following the hd in the above
statetments.

This setup command causes the stage1 located in /boot/grub on your machine
to be written to the mbr.

For My system, the above process looks like this --

grub
find /boot/grub/stage1 -> It comes back (hd0,1)
root (hd0,1)
setup (hd0)

I'm sure all of this can be accomplished from the graphical interface, but I
never made the switch, as I have gotten used to using this method over the
years. I have had to go through this every time I upgrade my system since
about 9.1 (I wish to hell I knew why!). For some reason, I never get a
clean MBR written when I upgrade. Every time, after I upgrade, I try to do
some more tweaking in the grub files hoping it will work right for the next
upgrade (it never does). I did some more tweaking since installing 10.0, so
I'm hoping I won't have that problem this next time (but I'd bet money I
will!). Good luck.

Greg Wallace



< Previous Next >
References