Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] date / time problems
  • From: Gil Weber <gil@xxxxxxxxxxxx>
  • Date: Mon, 3 Apr 2006 12:29:33 -0400
  • Message-id: <200604031229.33754.gil@xxxxxxxxxxxx>
On Sat March 4 2006 12:03 pm, John Moore wrote:
> I have SuSE 10.0 running at work and at home and it works great.
> Except I cannot -- either through the applet at the top of the screen
> or through YAST -- get SuSE to do the time right. I set the correct
> time and date and click Apply it doesn't stick. I even tried
> rebooting -- something you usually don't have to do -- but it made no
> difference. Sigh. Currently my time is correct but the date reads
> March 4 (should be April 3).
>
> I run Gnome so I am thinking this could be a Gnome bug. Any
> suggestions?
>
> John Moore
> Manager, IS
> Quality Care for Children
> Atlanta, GA


John, I was having similar problems with SuSE 10.0 on my laptop. Simply
would not maintain the settings. Here's how I finally got the date and
time to maintain the correct settings.

1) shut down computer
2) boot up into BIOS
3) Set time and date in BIOS, save settings and exit
4) Boot the machine and open YAST/System/Date&Time
5) Make sure system clock setting is UTC
6) On another computer open the webpage:
http://www.time.gov/timezone.cgi?UTC/s/0/java
7) On the first computer set the clock to correct time that you got from
the website in step 6 (or close to it)
8) Exit YAST cleanly
9) Open a terminal, become root, adjust the time on your desktop clock
by typing: ntpdate time.uh.edu
10) Still in the terminal, type:
hwclock --systohc
rm /etc/adjtime
11) Exit the terminal.


That should do it. My laptop has been rock-steady on time and date ever
since I did this.

Hope it helps.
Gil

< Previous Next >
References