Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
[9.3] apcupsd as netslave broken?
  • From: "T. Ribbrock" <admin_slox-e@xxxxxxxxx>
  • Date: Wed, 5 Apr 2006 14:09:18 +0200
  • Message-id: <20060405120917.GC17778@xxxxxxxxxxxxxxx>
Hi all,

I'm just after trying to get apcupsd to run in netslave mode on a SuSE
9.3 box. I was using the exact same configuration that I have working on a
SLOX 4.1 box, but apcupsd would just start and exit immediately upon
launch.

Running an strace against apcupsd (as I couldn't find any error messages
in the logs or using the -d switch) revealed that some subprocess exits
with a segmentation fault. I then tried a step-for-step configuration
changing one parameter in apcupsd.conf at a time until I finally
discovered that apcupsd would crash as soon as I chose "UPSMODE net". I
did not find any update for apcupsd for 9.3, nor did I manage to find the
bugtracker for 9.3 on Novell's site (yuck, yuck, yuck - the olde SuSE site
was much better...), so I decided to ask here... Has anybody come across
this?

BTW: I ended up installing the apcupsd from SuSE 10.0, which worked
without a problem with the same configuration, hence, I think it is a bug
in 9.3...

Cheerio,

Thomas


< Previous Next >
Follow Ups