Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] cron not recognizing changes to /etc/cron.d files [SOLVED]
  • From: Scott Leighton <helphand@xxxxxxxxxxx>
  • Date: Fri, 7 Apr 2006 19:39:38 -0800
  • Message-id: <200604072039.39008.helphand@xxxxxxxxxxx>
On Friday 07 April 2006 3:47 am, Carlos E. R. wrote:
>
> > My particular issue is that I've come to expect that the editor
> > I am primarily using, mcedit, acts right and changes the directory
> > timestamp. Unfortunately, it apparently doesn't always do so (which
> > is a whole new issue) since it acts one way on my home system
> > and a completely different way on my work system (I've compared
> > the ~/.mc/ini files on both systems, they are identical, so I don't
> > think it is a config issue, but I'm still looking).
>
> Interesting. Compare the mcedit versions (rpm -q mc) (mcedit --version)

I did, they are identical on both boxes.

#mcedit --version
GNU Midnight Commander 4.6.1-pre3
Virtual File System: tarfs, extfs, cpiofs, ftpfs, fish, undelfs
With builtin Editor
Using system-installed S-Lang library with terminfo database
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support

Also tried diff'ing the various config files in /usr/share/mc and
in ~/.mc and couldn't find anything different that seemed pertinent.

On the 64 bit box, mcedit creates a softlink in the current
directory for the file being edited, that apparently causes the
directory timestamp to update. On the 32 bit box, no softlink
is created and I have no idea at all why they act differently.

I've resigned myself to simply doing a rccron restart.

Scott



--
Vescere bracis meis
POPFile, the OpenSource EMail Classifier http://popfile.sourceforge.net/
Linux 2.6.11.4-21.11-default x86_64
SuSE Linux 9.3 (x86-64)

< Previous Next >
Follow Ups