Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] usb scanner only work as root after upgrade to SUSE 10
  • From: "Andre Truter" <andre.truter@xxxxxxxxx>
  • Date: Tue, 11 Apr 2006 21:56:08 +0200
  • Message-id: <173f0b9f0604111256o7c425e74i4a3dbb59e318f447@xxxxxxxxxxxxxx>
On 4/11/06, Johannes Meixner <jsmeix@xxxxxxx> wrote:
> On Apr 10 18:33 Andre Truter wrote (shortened):
> > I have an Epson Perfection 610 USB scaner which worked fine under SuSE 9.3.
> > Then I upgraded to SuSE 10.0 and now only root can use the scanner.
> > Normal users aparently don't have access to the scanner.
> > I googled and searched the mailing list, but did not find anything useful.
>
> See our support database.
>

I found the SDB entry, but it does not solve my problem, except if I
am missing something.

In my /etc/resmgr.conf.d/50-scanner.conf I do have the correct entry:

add usb:vendor=0x04b8,product=0x0103 scanner

If I run sane-find-scanner (as root and as normal user) I get the scanner:

found USB scanner (vendor=0x04b8 [EPSON], product=0x0103
[Perfection610 ]) at libusb:001:008

(As normal user it does not give the vendor and model name in brackets:

found USB scanner (vendor=0x04b8, product=0x0103) at libusb:001:008

I downloaded and installed the
sane-1.0.15-20.1.x86_64.ignore-EBUSY-from-USB.rpm package, but that
did not help either.

When I start xsane or kooka as normal user, the scanner is not available.

--
Andre Truter | Software Engineer | Registered Linux user #185282
ICQ #40935899 | AIM: trusoftzaf | http://www.trusoft.co.za

~ A dinosaur is a salamander designed to Mil Spec ~

< Previous Next >
Follow Ups