Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] Conflicts installing apt
  • From: Leendert Meyer <leen.meyer@xxxxxxx>
  • Date: Mon, 17 Apr 2006 10:15:22 +0200
  • Message-id: <200604171015.22507.leen.meyer@xxxxxxx>
On Sunday 16 April 2006 17:29, perlcgi2000 wrote:

...
> I downloaded install-apt4suse and installed it OK. However, when I try to
> use it I get this error:
...
> Linux:/home/nathan # install-apt4suse
> /usr/bin/install-apt4suse: line 144: [: missing `]'
> /usr/bin/install-apt4suse: line 144: 10.1: command not found

line 144 contains:

if [ "$SUSE_VERSION" = "10.0" || "10.1" ]; then

That is a syntax error. It should be:

if [ "$SUSE_VERSION" = "10.0" ] || [ "$SUSE_VERSION" = "10.1" ]; then

You could try to change this yourself: the file to edit
is /usr/bin/install-apt4suse.

Cheers,

Leen

< Previous Next >
References