Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] Faxing from 10.0
  • From: Mike McMullin <mwmcmlln@xxxxxxxx>
  • Date: Mon, 17 Apr 2006 18:48:01 -0400
  • Message-id: <1145314082.17664.14.camel@xxxxxxxxxxxxxx>
On Mon, 2006-04-17 at 18:28 -0400, Mike McMullin wrote:
> On Mon, 2006-04-17 at 16:20 +0200, Carlos E. R. wrote:

[snip}


> > If this works, then check what kdeprintfax is using to send faxes. Mine
> > (which I've never used, so it contains the defaults) says it uses:
> >
> > /usr/bin/sendfax -n %server_h %res %time_a %enterprise_x %comment_c %email_f -d %name_{@@@}%number %files
> >
> > which is the same command. I wonder if the syntax is entirely correct, I
> > dont see many command switches above.
>
> The fax system specified is hylafax, the default command line is:
> /usr/bin/capisuitefax -d %number %files
>
> IIRC capisuitefax was installed when I went into YaST to set up the
> fax.
> I want to note that I'm using kde 3.5.2.
>
> I do appreciate the help Carlos. I know I'm getting some where.

I switched your command line for mine and got the following in my log
files using kdeprintfax:
{
Apr 17 18:41:48.49: [21367]: SESSION BEGIN 000000028 *******
Apr 17 18:41:48.49: [21367]: HylaFAX (tm) Version 4.2.1
Apr 17 18:41:48.49: [21367]: SEND FAX: JOB 11 DEST ******* COMMID
000000028 DEVICE '/dev/ttyS4'
Apr 17 18:41:48.49: [21367]: STATE CHANGE: RUNNING -> SENDING
Apr 17 18:41:48.49: [21367]: MODEM input buffering enabled
Apr 17 18:41:48.49: [21367]: <-- [9:AT+FLO=2\r]
Apr 17 18:41:48.60: [21367]: --> [2:OK]
Apr 17 18:41:48.60: [21367]: <-- [9:AT+FPP=0\r]
Apr 17 18:41:48.71: [21367]: --> [2:OK]
Apr 17 18:41:48.72: [21367]: <-- [9:AT+FBO=0\r]
Apr 17 18:41:48.83: [21367]: --> [2:OK]
Apr 17 18:41:48.83: [21367]: <-- [10:AT+FCT=30\r]
Apr 17 18:41:48.94: [21367]: --> [2:OK]
Apr 17 18:41:48.94: [21367]: <-- [15:AT+FNR=1,1,1,0\r]
Apr 17 18:41:49.06: [21367]: --> [2:OK]
Apr 17 18:41:49.06: [21367]: <-- [9:AT+FIE=0\r]
Apr 17 18:41:49.18: [21367]: --> [2:OK]
Apr 17 18:41:49.23: [21367]: <-- [9:AT+FBU=0\r]
Apr 17 18:41:49.34: [21367]: --> [2:OK]
Apr 17 18:41:49.34: [21367]: <-- [23:AT+FCC=1,5,2,2,0,0,0,0\r]
Apr 17 18:41:49.46: [21367]: --> [2:OK]
Apr 17 18:41:49.47: [21367]: DIAL *******
Apr 17 18:41:49.47: [21367]: <-- [12:ATDT*******\r]
Apr 17 18:41:51.58: [21367]: --> [12:NO DIAL TONE]
Apr 17 18:41:51.58: [21367]: SEND FAILED: JOB 11 DEST 8901928 ERR No
local dialtone
Apr 17 18:41:51.58: [21367]: <-- [5:ATH0\r]
Apr 17 18:41:51.69: [21367]: --> [2:OK]
Apr 17 18:41:51.69: [21367]: MODEM set DTR OFF
Apr 17 18:41:51.69: [21367]: STATE CHANGE: SENDING -> MODEMWAIT (timeout
5)
Apr 17 18:41:51.69: [21367]: SESSION END
}

The not dial tone makes sense here. I unplugged the modem from the
wall just prior to trying this. (Expected in-coming phone call.)


< Previous Next >
Follow Ups