Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Attention: Lots of SUSE packages are packaged incorrect
  • From: "Alexey Eremenko" <al4321@xxxxxxxxx>
  • Date: Wed, 19 Apr 2006 16:48:40 -0200
  • Message-id: <7fac565a0604191148l641dcee9w6af043bdcc84ffe0@xxxxxxxxxxxxxx>
Hi all !

I would like to discuss with the SUSE community one mistake commonly
done by SUSE packagers: more specifically - the RPM architecture in
SUSE.

I have found a LOT of noarch packages built for the i586 architecture
in SUSE Linux 10.0.

I propose to people to identify those packages, that should be made
"noarch" but for some obscure reason are not.

Most packages that were built in the incorrect way were documentation,
but some others were written in Interpreted languages. (like Python)

One example of interpreted language package that is i586 but should be
noarch is :
"eric" IDE

I have not dive too deep, but I'm sure there are other examples.

The other incorrectly packaged packages are docs - quick search returns me:

linux:/mnt/cdrom/suse/i586 # ls | grep doc | sort | cat -n
1 apache2-doc-2.0.54-10.i586.rpm
2 atk-doc-1.10.3-2.i586.rpm
3 at-spi-doc-1.6.6-2.i586.rpm
4 bind-doc-9.3.1-8.i586.rpm
5 cvs-doc-1.12.12-4.i586.rpm
6 docbook2x-0.8.5-5.i586.rpm
7 gconf2-doc-2.12.0-2.i586.rpm
8 glib2-doc-2.8.1-3.i586.rpm
9 gnome-doc-utils-0.4.0-2.i586.rpm
10 gnome-panel-doc-2.12.0-5.i586.rpm
11 gnome-vfs2-doc-2.12.0-9.i586.rpm
12 gtk2-doc-2.8.3-4.i586.rpm
13 gtksourceview-doc-1.4.1-2.i586.rpm
14 kdelibs3-doc-3.4.2-24.i586.rpm
15 krb5-doc-1.4.1-5.i586.rpm
16 libbonobo-doc-2.10.1-3.i586.rpm
17 libbonoboui-doc-2.10.1-3.i586.rpm
18 libglade2-doc-2.5.1-9.i586.rpm
19 libgnomecanvas-doc-2.12.0-2.i586.rpm
20 libgnome-doc-2.12.0.1-2.i586.rpm
21 libgnomeprint-doc-2.12.0-4.i586.rpm
22 libgnomeprintui-doc-2.12.0-3.i586.rpm
23 libgnomeui-doc-2.12.0-3.i586.rpm
24 libgsf-doc-1.12.1-3.i586.rpm
25 libicu-doc-3.4-3.i586.rpm
26 libreadline-java-javadoc-0.8.0-11.i586.rpm
27 lilypond-documentation-2.6.3-2.i586.rpm
28 python-twisted-doc-2.0.0-2.i586.rpm
29 qt3-devel-doc-3.3.4-28.i586.rpm
30 samba-doc-3.0.20-4.i586.rpm
31 xen-doc-html-3.0_6715-2.i586.rpm
32 xen-doc-pdf-3.0_6715-2.i586.rpm
33 xen-doc-ps-3.0_6715-2.i586.rpm

now, 33 doc packages are i386 ? And, of course all of them contain
binaries, huh!
:)
Look, it wastes time & server space to get noarch packges built for
different platforms.

Why is this ?

OS: SUSE Linux 10.0

-Alexey Eremenko. 19.04.2006.
< Previous Next >
Follow Ups