Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] ndiswrapper on suse 9.3
  • From: Jerry Feldman <gaf@xxxxxxx>
  • Date: Mon, 24 Apr 2006 13:40:32 -0400
  • Message-id: <200604241340.32422.gaf@xxxxxxx>
On Monday 24 April 2006 12:20 pm, Paul Howie wrote:

> The device is detected ok (bus 1 device 3):
>
> # lsusb
> Bus 001 Device 004: ID 047d:101f Kensington
> Bus 001 Device 003: ID 07d1:3c03 D-Link System
> Bus 001 Device 001: ID 0000:0000
Unfortunately, I do not have the same device. My device is a Broadcom 4319
Airforce chip on the mother board.
In your case, you have a device that is detected at PCIID 07d1:3c03.
From the previous posts, ndiswrapper is able to validate the driver and
detect the hardware, but you stated that the driver is the wrong driver for
the architecture.

On my system, AMD-64 with a 64-bit SuSE 10.0, with the 32-bit driver
"ndiswrapper -l" reported hardware present, but when the driver was loaded
(by modprobe) the driver actually faulted. When I initially tried the
64-bit driver, ndiswrapper -l reported:
gaf@gaflap:~> ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present

In my specific case, I ran:
ndiswrapper -d 14e4:4319 bcmwl5

Then ndiswrapper -l reports
bcmwl5 driver present, hardware present

As soon as I did this and loaded the module (modprobe ndiswrapper), dmesg
indicated a successful load of the driver and wlan0 appeared. You may be
reporting it as eth1.

You might also try "ndiswrapper -hotplug" since your device is a USB device.
--
Jerry Feldman <gaf@xxxxxxx>
Boston Linux and Unix user group
http://www.blu.org PGP key id:C5061EA9
PGP Key fingerprint:053C 73EC 3AC1 5C44 3E14 9245 FB00 3ED5 C506 1EA9

< Previous Next >
Follow Ups