Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] ndiswrapper on suse 9.3
  • From: "Paul Howie" <paulhowie@xxxxxxxxx>
  • Date: Mon, 24 Apr 2006 21:11:49 +0200
  • Message-id: <6b8127150604241211j4dc8f339rc01b71ab558ee1ca@xxxxxxxxxxxxxx>
On 24/04/06, Jerry Feldman <gaf@xxxxxxx> wrote:
> From the previous posts, ndiswrapper is able to validate the driver and
> detect the hardware, but you stated that the driver is the wrong driver for
> the architecture.

Not any more, I was getting an error message in dmesg about the driver
being non-32 bit, so I found another driver and now I'm not getting
any errors at all.

> On my system, AMD-64 with a 64-bit SuSE 10.0, with the 32-bit driver
> "ndiswrapper -l" reported hardware present, but when the driver was loaded
> (by modprobe) the driver actually faulted. When I initially tried the
> 64-bit driver, ndiswrapper -l reported:
> gaf@gaflap:~> ndiswrapper -l
> Installed ndis drivers:
> bcmwl5 driver present
>
> In my specific case, I ran:
> ndiswrapper -d 14e4:4319 bcmwl5
>
> Then ndiswrapper -l reports
> bcmwl5 driver present, hardware present

I had much the same results with the 64-bit driver before, but with
the 32-bit one everything seems to be going ok. I get the driver
present, hardware present message and dmesg confirms that ndiswrapper
is being loaded correctly. I tried specifying the ID anyway, just in
case it helped, no joy.

> As soon as I did this and loaded the module (modprobe ndiswrapper), dmesg
> indicated a successful load of the driver and wlan0 appeared. You may be
> reporting it as eth1.

Unfortunately this seems to be where I'm having trouble. For some
reason I'm not getting any additional interfaces come up once the
driver is loaded. that is, if "ifconfig -a" would tell me about it
like I assume it should. All I have are lo, eth0 (my wired network
card) and sit0.

> You might also try "ndiswrapper -hotplug" since your device is a USB device.

A good idea, but it doesn't seem to have improved matters.

I also found that there is a native linux driver available for the
device. I've compiled it and used insmod to load it but that doesn't
seem to be working either... I'm probably missing something simple.
I'll probably wait until suse 10.1 is out since I'm already planning
to upgrade. Hopefully things will go more smoothly for that.

Thanks for all the help. If you have any more ideas I'd love to hear them.

-- Paul

< Previous Next >