Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [opensuse] Problem With Sendmail in 10.1 Beta 5 and Beta 9
  • From: Tim Harper <tim@xxxxxxxxxxxx>
  • Date: Mon, 17 Apr 2006 14:17:25 -0600
  • Message-id: <200604171417.25649.tim@xxxxxxxxxxxx>
On Monday 17 April 2006 14:10, Scott Alan Chaffin wrote:
> When installing sendmail (instead of postfix) in the default location of
> /usr/sbin/sendmail, the mail daemon doesn't start, only the queue
> handler. Attempting to start the daemon by hand results in the
> following error:
>
> huron:/usr/sbin # ./sendmail -bD -q15m
> 451 4.0.0 opendaemonsocket: daemon MTA: cannot bind: Permission denied
> 421 4.0.0 opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
> huron:/usr/sbin #
>
> When I move the sendmail binary to /usr/lib and make a symbolic link to
> /usr/sbin, it starts as expected, both on the command line and in the
> /etc/init.d/sendmail script.
>
> It's only a minor inconvenience to start things this way, but it is an
> inconvenience. I suspect that this is related to some sort of enhanced
> security on /usr/sbin. The file system is reiserfs.
>
> Does anyone know how to rectify this condition?
>
> Thanks,
>
> Scott
Hello there Scott,

When I run the command:
/usr/sbin/sendmail -bD -q15m
I get "sendmail: fatal: unsupported: -bD"

However, when I run "./sendmail -bd -q15m", it works.

Was -bD a typo? And, can you upgrade to Suse 10.1 RC1? I was able to do so
using "smart"

good luck to you pal,
Tim

< Previous Next >
Follow Ups
References