Mailinglist Archive: opensuse (3767 mails)

< Previous Next >
Re: [SLE] GIMP will not start...
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Wed, 1 Feb 2006 01:57:21 +0100 (CET)
  • Message-id: <Pine.LNX.4.61.0602010140020.13475@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


The Tuesday 2006-01-31 at 18:24 +0100, Johnny Ernst Nielsen wrote:

> > Or you could try tweaking something there, but I don't know what.
> > File 'gimprc' seems to be the main config.
>
> I have no idea what settings i should try to fiddle with.
> Especially since the Gimp runs fine on my computer, but not on my
> mother's, and the software installations are identical.
> The computers differ only with regards to hardware.

Perhaps... try reducing memory used. You can look the variables in
"/etc/gimp-2.2/gimprc". These seem interesting:

# There is always a tradeoff between memory usage and speed. In most cases,
# the GIMP opts for speed over memory. However, if memory is a big issue,
# try to enable this setting. Possible values are yes and no.
#
# (stingy-memory-use no)

Try "yes".


# (tile-cache-size 128M)

Try a lower setting.



> > If you start gimp from an xterm you might see an error message.
>
> Yes. The message is:
> hanne@comp:~> gimp
> Illegal instruction (SIGILL)
> hanne@comp:~>

It seems a bug in gimp that surfaces with your hardware. I see that gimp
has some options:

--verbose Show startup messages.
-c, --console-messages Display warnings to console instead of a dialog box.
--debug-handlers Enable non-fatal debugging signal handlers.
--stack-trace-mode <never | query | always>
Debugging mode for fatal signals.

But I doubt they might help here.



> mmap2(NULL, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x411e4000
> munmap(0x411e4000, 32768) = 0
> open("/home/hanne/.gimp-2.2/gimpswap.5863", O_RDWR|O_CREAT|O_LARGEFILE, 0600) = 4
> close(4) = 0
> unlink("/home/hanne/.gimp-2.2/gimpswap.5863") = 0
> --- SIGILL (Illegal instruction) @ 0 (0) ---
> +++ killed by SIGILL +++


It seems a problem after opening the local swap file. The partition has no
problems, and is local, I suppose?

- --
Cheers,
Carlos Robinson

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFD4Ad7tTMYHG2NR9URAon1AJ0TC6esvp11J+PIywpaNbmjLwizzACfaknt
LKhuax2IleOagIAgeniUhQY=
=MpNj
-----END PGP SIGNATURE-----


< Previous Next >