Mailinglist Archive: opensuse (3767 mails)

< Previous Next >
Re: [SLE] Dual Boot Under Grub
  • From: Lucky Leavell <susemisc@xxxxxxxxxxxxx>
  • Date: Mon, 6 Feb 2006 00:05:20 -0500 (EST)
  • Message-id: <Pine.LNX.4.63.0602052358070.5950@xxxxxxxxxxxxxxxxxxxxxxxxx>
On Sun, 5 Feb 2006, Darryl Gregorash wrote:

> On 03/02/06 20:31, Lucky Leavell wrote:
> >and doing a system check/repair. It worked fine until I deleted the
> >Windows section and then tried to put it back.
> >
> Run "fdisk -l /dev/hda" and see if there is a * in the "boot" column for
> the hda1 line. If not, then you need a "makeactive" command in the grub
> menu entry. This must be put between the "rootnoverify" and
> "chainloader" commands.
>
/dev/hda1 is active but fdisk shows the type as "b"?

I did a system repair and the fstab section for /dev/hda1 (the Win 95
FAT32 partition) as removed (actually marked Ignore). The boot loader part
removed then all references to the Windows section. It would appear that
my removing the Windows section from grub (via YaST) somehow damaged the
Windows partition such that it can no longer boot. (Is this possible?)
(I thought I was simply removing that section of menu.lst and nothing more
serious BUT Windows is rather fragile!

Methinks I have two or three options:

1. Run Repair again, replacing the original MBR
2. Try switching to LILO
3. Start over reinstalling from scratch and then SuSE (changing
partition sizes in the process)

Comments or Suggestions?

Thank you,
Lucky

< Previous Next >