Mailinglist Archive: opensuse (3336 mails)

< Previous Next >
Re: [SLE] NEW KDE 3.5 Upgrade Problem -- python-qt AND MORE!
  • From: Graham Anderson <graham.anderson@xxxxxxxxx>
  • Date: Fri, 02 Dec 2005 02:12:51 +0000
  • Message-id: <438FADA3.3020503@xxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

An acknowledgement that python-qt was missing from KDE Supplimentary was
posted to [SLE] list on Wednesday.

It *should* appear any time now... ;)

cheers the noo...
Graham

Robert Paulsen wrote:
> On Thursday 01 December 2005 03:50, Francesco Teodori wrote:
>> Skip the kdebindings3-python package. It's what I did and everything work.
>> Francesco
>>
>> Robert Paulsen wrote:
>>> I have the pre-release KDE 3.5 installed OK on SuSE 9.3. Got it from SuSE
>>> supplementary source via YaST's "Install and Remove Software" about a
>>> week ago.
>>>
>>> Now I want to update to the official 3.5 release but ran into a problem.
>>> It has a missing dependency: kdebindings3-python requires python-qt which
>>> is apparently not available. The pre-release 3.5 version does not have
>>> this package but it also didn't call it out as a dependency.
>>>
>>> kdebindings3-python is required in turn by hplip -- needed by CUPS to
>>> support my HP Laserjet printer.
>>>
>>> So, it seems I cannot install the official KDE 3.5.
>>>
>>> Does anyone have a way around this?
>>>
>>> Bob
>
> Well, things have gone down hill! I decided to take all the advice and not
> install the kdebinding3-python package. Unfortunately when I now run "Install
> and Remove Software" I get some *additional* missing dependencies and
> conflicts. Here is a summary. Yes, it does read like nonsense.
>
> + installed not available
> + is not available
> + not not available
> + k3b 0.12.8-3b.pm.2 conflict
> + kdebindings3-python 3.5.0-8 conflict
> + python-qt not available
>
> two days ago I only got the last one (or two) messages. Clicking on the "+"
> next to k3b gives an interesting result:
>
> k3b requires is
> k3b requires not
> k3b requires installed
>
> My *guess* is that someone updated k3b on the servers but got the rpm SPEC
> file wrong. It thinks it requires three packages named "is", "not", and
> "installed"!
>
> I tried the main SuSE ftp site and two mirrors and got the same results. Just
> in case something went wrong with my system I tried "rpm --rebuilddb" but
> that made no difference.
>
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDj62jE7J2/DSrgDcRAlWQAJ9tcorStGGKElU0C5be2A4cKSl+hgCdHkxA
6KxVlFpCHl9O+JBL0wSKu48=
=h8JB
-----END PGP SIGNATURE-----

< Previous Next >