Mailinglist Archive: opensuse (2700 mails)

< Previous Next >
Re: [SLE] SuSE 9.1, OpenLDAP fine as user ldap, OpenLDAP/TLS only works as user root
  • From: Jason Joines <support@xxxxxxxxxxxxxxx>
  • Date: Fri, 01 Jul 2005 12:13:29 -0500
  • Message-id: <42C579B9.6070006@xxxxxxxxxxxxxxx>
Heinzmann, Robert wrote:

Hello,
I've seen your post on
http://lists.suse.com/archive/suse-linux-e/2004-Oct/1152.html.

Same problem here !!

Same situation, If i run ldap as root everything is OK. As soon as I set
-u and -g ist not working -- MOST OF THE TIME!. Sometimes it works even
with -u ldap and -g ldap.
Have you found a solution for the problem yet ? Unfortunately your
posting does not continue.

Regards, Robert


Robert,

Someone else contacted me with that same question a bit over a month
ago. Here's the thread.

Jason
===========


-------- Original Message --------
Subject: Re: TLS/SSL error in OpenLDAP
Date: Mon, 16 May 2005 22:31:18 -0400
From: Prakash Velayutham
To: Jason Joines



Jason Joines 05/16/05 6:02 PM >>>
Prakash Velayutham wrote:

Jason Joines wrote:

Prakash Velayutham wrote:

Hi,

I noticed your thread in suse-linux-e forum regarding the OpenLDAP
SSL/TLS issues. I am having the same issues as you mention in that
thread. Could you please let me know how you solved it?
When I start slapd without -u or -g, I am able to ldapsearch with
-ZZ
from a client successfully. But when I include the -u and -g (either
as
root or as ldap user), ldapsearch with -ZZ fails.

Thanks,
Prakash

SuSE-9.0 Prof
openldap2-2.1.22-118
openssl-0.9.7b-133

Thanks,
Prakash

Could you provide the date and subject of the original post. I post a lot so I don't remember that one in particular and need to look it up.

Jason
===========


Date - Fri Oct 08 2004 - 19:32:13 CEST
Subject - SuSE 9.1, OpenLDAP fine as user ldap, OpenLDAP/TLS only works as user root

Thanks,
Prakash


Sorry, been outta the office for awhile. I just now got to go back and look at that thread. I can't remember doing anything to solve it. However, I do still have a 9.1 box running OpenLDAP/TLS so maybe we can compare settings and see if that helps.

Jason

Hi Jason,

Thanks for the reply. I solved the issue. It was just that my Slave LDAP
server's /etc/ldap.conf was looking at itself for LDAP, but
/etc/openldap/ldap.conf was looking at Master LDAP server. Changed the
/etc/openldap/ldap.conf host entry and everything started working like a
charm.

Prakash




< Previous Next >
This Thread
  • No further messages