Mailinglist Archive: opensuse (2700 mails)

< Previous Next >
Re: [SLE] glabels error: no libglabels.so.1
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Fri, 01 Jul 2005 23:53:18 +0100
  • Message-id: <42C5C95E.4090708@xxxxxxxxxxxxxxxx>
ken wrote:
Sid Boyce wrote:


ken wrote:


I just installed glabels-2.0.2-3 and the glabels-debuginfo of the same
version. No problem. But then I tried to run it from CLI and got the
error message:

"error while loading shared libraries: libglabels.so.1: cannot open
shared object file: No such file or directory"

So I looked for the libglabels package in the suse areas of a couple of
ftp sites and couldn't find it. I did find a libglabels.so packaged by
a third party, but I'm always a little hesitant about downloading
something from someone I don't know.

How have other people gotten around this? (I already tried compiling
the glabels src.rpm, but it horked. So that's not an option for me.)

tia,
ken


Does the symlink exist. I had the same problem with something
(glabels??) and it was missing. If missing "ln -s
/opt/gnome/lib/libglabels.so.1.0.1 /opt/gnome/lib/libglabels.so.1",
then run ldconfig.



I don't have /opt/gnome/lib/libglabels.* at all.


# rpm -qpl glabels-2.0.2-3.i586.rpm (on the 9.3 DVD)
/opt/gnome/lib/libglabels.a
/opt/gnome/lib/libglabels.la
/opt/gnome/lib/libglabels.so.1.0.1
I now remember, I had to make the symlink for libglabels.so.1, do ldconfig and it worked.
I also downloaded the sources and built 2.1.0, then installed the RPM built by checkinstall.
Regards
Sid.
--
Sid Boyce ... Hamradio License G3VBV, Keen licensed Private Pilot
Retired IBM Mainframes and Sun Servers Tech Support Specialist
Microsoft Windows Free Zone - Linux used for all Computing Tasks

< Previous Next >
This Thread
Follow Ups
References