Mailinglist Archive: opensuse (2700 mails)

< Previous Next >
Re: [SLE] Puzzling gtk2 issue
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Sat, 02 Jul 2005 00:27:01 +0100
  • Message-id: <42C5D145.4020407@xxxxxxxxxxxxxxxx>
Trey Sizemore wrote:
On Fri, 2005-07-01 at 22:11 +0100, Sid Boyce wrote:

Trey Sizemore wrote:

I've been compiling sylpheed-claws from CVS for several weeks on my SUSE
9.3 box with no issues. For the past week, it has failed to compile and
gives the following error:

<snip>
checking for library containing encrypt... -lcrypt
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.4.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log
for the
*** exact error that occured. This usually means GTK+ is incorrectly
installed.
configure: error: Test for GTK failed. See the file 'INSTALL' for help.

I've done some upgrades via apt over the past month, so something may
have happened there, but I've not been able to trace the cause of the
issue. I'm hoping someone might be able to point me in the right
direction as far as what to check.


salamander:/home/trey # pkg-config gtk+-2.0 --cflags
-DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/opt/gnome/include/gtk-2.0
-I/opt/gnome/lib/gtk-2.0/include -I/usr/X11R6/include
-I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/pango-1.0
-I/usr/include/freetype2 -I/usr/include/freetype2/config
-I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include

Thanks.



Check gtk2-devel is installed.
Regards
Sid.


Yes, it's installed:

salamander:/home/trey # rpm -qa | grep gtk2
gtk2-themes-0.1-637
gtk2_prefs-0.3.2-1.guru.suse93
gtk2-engines-2.6.2-4
gtk2-devel-2.6.4-6
gtk2-clearlooks-0.6-1.guru.suse93
libswt3-gtk2-3.0.1-3
eclipse-gtk2-3.0.1-3
gtk2-themes-rpanther2-20040808-1suse93
gtk2-doc-2.6.4-6
gtk2-2.6.4-6
gtk2-themes-ale-panther-1.0-1.guru.suse93


# rpm -qa|grep gtk2
gtk2-themes-0.1-637
gtk2-devel-2.6.4-6
gtk2-engines-2.6.2-4
gtk2-doc-2.6.4-6
eclipse-gtk2-3.0.1-3
gtk2-2.6.4-6
libswt3-gtk2-3.0.1-3

sylpheed-claws-1.9.12cvs10 latest snapshot downloaded a few minutes ago after this error --
# cvs -d:pserver:anonymous@xxxxxxxxxxxxxxxxxxx:/cvsroot/sylpheed-claws login
Logging in to :pserver:anonymous@xxxxxxxxxxxxxxxxxxx:2401/cvsroot/sylpheed-claws
CVS password:
cvs [login aborted]: unrecognized auth response from cvs.sourceforge.net: cvs pserver: cannot read /cvsroot/sylpheed-claws/CVSROOT/config: Input/output error

# ./configure
checking OPENSSL_LIBS... -lssl -lcrypto -ldl
checking for library containing encrypt... -lcrypt
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.4.0... yes (version 2.6.4)
<STUFF OMITTED>
sylpheed-claws 1.9.12cvs10

JPilot : no
LDAP : no
OpenSSL : yes
iconv : yes
compface : no
IPv6 : yes
GNU/aspell : no
Crash dialog : no
Plugins : clamav dillo-viewer pgpmime trayicon
Config dir : .sylpheed-gtk2

The binary will be installed in /usr/local/bin

Configure finished, type 'make' to build.


This is on 9.3 x86.
Regards
Sid.
--
Sid Boyce ... Hamradio License G3VBV, Keen licensed Private Pilot
Retired IBM Mainframes and Sun Servers Tech Support Specialist
Microsoft Windows Free Zone - Linux used for all Computing Tasks

< Previous Next >