Mailinglist Archive: opensuse (2700 mails)

< Previous Next >
kaffeine and VLC install? (was: Qt version issue.)
  • From: mikael persson <zen22843@xxxxxxxxx>
  • Date: Sun, 03 Jul 2005 16:20:32 +0100
  • Message-id: <42C80240.4030204@xxxxxxxxx>
>>Hello list,
>>I am trying to install the latest version of kaffeine in hope of being
>>able to watch DVDs and other avi formats. But it complains over a Qt error:
>>
>>------------------------------------
>>checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers
>>and libraries) not found. Please check your installation!
>>For more details about this problem, look at the end of config.log.
>>------------------------------------
>>
>>the config.log doesn't tell me much really. Strange thing is that YAST
>>claims that that version of Qt is installed.
>
>
> To run something that uses qt you need qt3 installed, but to compile that
> something you need qt3-devel, so make sure you have that installed
>

Ah, I see. Yes, I bumped into something similar earlier. Now I am getting some other error that I don't know how to handle.

------------------------------------
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
------------------------------------
This happens when I am running configure to get Kaffeine installed. Any ideas of what I have to do? I am running KDE.

>>I've also tried installing
>>the latest Qt version from trolltech. But that install gives me some
>>serious errors.
>
>
> Whoa there, you can't use qt4 as a drop-in replacement of qt3. Programs need
> to be ported in order to be able to use qt4
>

oh. I guess I am too used to w2k. Just grabb the latest and be happy.

My original reason for trying that kaffeine install, is to be able to handle DVD's among other things. Without the libdvdcss library, will I be?

How do you get libraries to stick in the system? So other installs can be aware of them? Sometimes it works fine, but other times not.
I have also tried installing the VideoLan player but it stumbles on a couple of dependencies, the first being libdvdcss. I downloaded and installed libdvdcss with configure, make and make install. But VLC is still asking for that library. Any idea of what I can be doing wrong?

I hope you can stand my very basic questions. But we all have to start somewhere.

Thanks for the help so far,
Mikael

< Previous Next >
Follow Ups