Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Re: IPv6 & SuSE 9.2
  • From: James Knott <james.knott@xxxxxxxxxx>
  • Date: Fri, 06 May 2005 16:09:39 -0400
  • Message-id: <427BCF03.7090901@xxxxxxxxxx>
James Wright wrote:


James Knott wrote:

George Barnett wrote:

James Wright wrote:

To see if it is your switch that is causing the problems, you can try using a crossover cable to directly connect two of the computers directly, and see if you can establish some communication. If you can, it is probably your switch. If it is your switch, you can try to find a firmware upgrade that allows IPv6. Or put a second network card in each computer and forget the switch, but using a switch would be much easier to manage.




A switch is a layer 2 device, unless it's capable of routing, which is unlikely in this case. All the switch cares is that a 1500byte packet comes in and is switched to a destination port based on the MAC. It doesn't care if it's IP or IPX or Appletalk or whatever.

Check the arp tables on the boxes and check the subnet masks on the boxes.



As I have mentioned, the ping is being received. The problem is that there's no reply. Given that the ping attempt is seen at the destination, rules out network problems.

The situation is as follows

Computer A can ping itself and get response.
Computer B can ping itself and get response.
Computer A can ping B. Ethereal, running on B, shows "Neighbor Solicitation" from A, but does not show any response. Computer A shows "From ::1 icmp_seq=6 Destination unreachable: Address unreachable"

A good ping of a computer to itself shows:

jknott@linux:~> ping6 -I eth0 fe80::205:5dff:fef6:4ce
PING fe80::205:5dff:fef6:4ce(fe80::205:5dff:fef6:4ce) from ::1 eth0: 56 data bytes
64 bytes from fe80::205:5dff:fef6:4ce: icmp_seq=1 ttl=64 time=0.046 ms
64 bytes from fe80::205:5dff:fef6:4ce: icmp_seq=2 ttl=64 time=0.050 ms
64 bytes from fe80::205:5dff:fef6:4ce: icmp_seq=3 ttl=64 time=0.053 ms
64 bytes from fe80::205:5dff:fef6:4ce: icmp_seq=4 ttl=64 time=0.050 ms


Incidentally, "Neighbor Solicitation" is the IPv6 version of arp request. So, the problem appears to be that the remote system is not responding to the IPv6 version of an arp request.


First I apologize for my ignorance about switches. Secondly, here is a troubleshooting list for IPv6 from http://www.cs-ipv6.lancs.ac.uk/ipv6/systems/linux/bieringer/IPv6-HOWTO/IPv6-HOWTO-6.html#etc-protocols

that was linked from
http://www.cs-ipv6.lancs.ac.uk/ipv6/systems/linux/bieringer/IPv6-HOWTO/IPv6-HOWTO-6.html#Cannotping

I hope this helps.

tnx

As I mentioned in another note, I've found that the problem doesn't occur between two SuSE 9.2 systems. Only between 9.2 and 9.1. I'll have to do some more investigating as to why. However, I can still try further experimenting, but it means that I'll have to use my notebook as the 2nd system, since it has 9.2 installed.

< Previous Next >
Follow Ups