Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Networking CUPS?
  • From: "Hylton Conacher (ZR1HPC)" <hylton@xxxxxxxxxxxx>
  • Date: Sat, 07 May 2005 18:43:58 +0200
  • Message-id: <427CF04E.5010001@xxxxxxxxxxxx>
Sid Boyce wrote:
Hylton Conacher (ZR1HPC) wrote:

I ran the 'tail command on tee client after stopping the server 'tail'. Saw nothing and refreshed a few times.

lpq on the client with "tcpdump -i eth0" running, /etc/cups/client.conf has the line "ServerName barrabas.site".

Sorry, that's my hostname, substitute yours.
Nevermind, picked it up when I was viewing the files and just entered my
server IP as the servername.

The server should be the one doing the broadcasts. On the client "ps fax|grep cups" shows cupsd (server) isn't running which is correct, on the server ---
barrabas:/ftp/May05/MPlayer-1.0pre7 # ps fax|grep cups
22890 pts/3 S+ 0:00 | | \_ grep cups
9669 ? Ss 0:00 /usr/sbin/cupsd


All I get is the '22890...' line, no '9669.....' line.

All you got above means the server is not running.
NO Wonder I am not seeing network activity in the form of IPP broadcasts.

You could try running
"cupsd" from the command line, check with ps that it's running and if not, there should be something in /var/log/cups/error_log. Until the server is up and running, there will be no ipp network broadcasts.
When I ran rccups on the server the following was displayed:
Server:
# rccups start
Starting cups
#cupsd: Child exited with status 98!
( I had to Ctrl-C to get back to the #)

Client:
#rccups start
Shutdown cups
Restarting cups
#

I had the same results when I ran #'rccups restart'

[snip]

Also " lppasswd -a root" or you will get access errors from "http://localhost:631";.
Thanks for that. It partially solved getting into the CUPS web
interface, on the client anyway.

Server:
When I did a #'lppasswd -a root' on the server, the command completed
OK, but when I tried to access the CUPS docs by entering in
'http://localhost:631' on the address bar of Firefox, the server quickly
came back and told me that 'Connection refused whilst attempting to
connect to localhost:631'. Even if I try and enter 'localhost:631' in a
konqueror window, Firefox still strarts up and gives me the message.

Client:
Command completed no problem and I was able to get into the web admin
interface using Mozilla Navigator, but after clicking on 'printers' and
'admin' the interface went belly up and displayed nothing but a white
screen. The browser back button didn't help either.

YaST should also have setup stuff in /etc/cups/, printers.conf and printcap.
That I'll look into later. At the moment I need to find out what cups
error 98 is as I cannot find it via the SuSE help access to the CUPS
manual.
I also need to get cups started at boot. but for the life of me I do not
know where to get it to start at boot. When I went into 'Network
services' under Yast there was no cups service listed there and asides
from that I didn't know all the details to add it in.

Regards
--
========================================================================
Hylton Conacher - Linux user # 229959 at http://counter.li.org
Currently using SuSE 9.0 Professional with KDE 3.1
========================================================================




< Previous Next >