Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Networking CUPS?
  • From: "Hylton Conacher (ZR1HPC)" <hylton@xxxxxxxxxxxx>
  • Date: Sun, 15 May 2005 11:03:59 +0200
  • Message-id: <4287107F.5040309@xxxxxxxxxxxx>
Sorry to all those helping me with this thread. I started work at a new company and have not had the energy for email when I arrive home late.

Joe Morris (NTM) wrote:
Hylton Conacher (ZR1HPC) wrote:

hylton@Umalusi:~> lpstat -t
lpstat:Unable to connect to server: connection refused

I believe it is refused because the server is not running.
How can I get the server started and running on system boot? I would assume rccups restart would work but see below:

All I get is an error number 98 when I rccups restart. Below is the last
few lines copied and pasted from the SERVERS /var/log/cups/error_log as it was booted. Client brought online after server:
I [07/May/2005:19:41:12 +0200] Listening to 0:631
I [07/May/2005:19:41:12 +0200] Listening to 0:631
I [07/May/2005:19:41:12 +0200] Sending browsing info to c0a800ff:631
E [07/May/2005:19:41:12 +0200] httpGetHostByName("@LOCAL ###### This has to be set") failed - Host name lookup failure!

This needs fixed.
What is causing this and how can I fix this this hostname lookup failure?

E [07/May/2005:19:41:12 +0200] Bad BrowseAddress @LOCAL ###### This has to be set at line 537.
E [07/May/2005:19:41:12 +0200] Unknown directive # on line 801.
E [07/May/2005:19:41:12 +0200] Unknown directive # on line 802.
E [07/May/2005:19:41:12 +0200] Unknown Location directive # on line 833.

You should check each of the bad lines above in your /etc/cups/cupsd.conf
Thanks. I do not understand the Bad BrowseAddress though. The #'s were just comment fields.

[snip]
E [07/May/2005:19:41:16 +0200] StartListening: Unable to find IP address for server name "192.168.0.1 # Use an IP address as it is less prone to error" - Host name lookup failure

Is this address reachable?
Most definitely! It is the address of my server which I can ping.


E [07/May/2005:19:41:16 +0200] StartListening: Unable to bind socket for address 00000000:631 - Address already in use.

The reason the server is not running, it can't finish starting. I believe correcting the above errors will get you going.
I agree, but where can I find an explanation on my local machine about the error 98 that rccups gives when restarted?

--
========================================================================
Hylton Conacher - Linux user # 229959 at http://counter.li.org
Currently using SuSE 9.0 Professional with KDE 3.1
========================================================================



< Previous Next >
Follow Ups