Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Java JRE 1.5
  • From: Kornelis Sietsma <korny@xxxxxxxxxxx>
  • Date: Sat, 21 May 2005 18:22:26 +1000
  • Message-id: <428EEFC2.7010102@xxxxxxxxxxx>
John Bailo wrote:
Is there a Suse 9.2 compatible JRE 1.5 RPM anywhere?

The distro seems to require 1.4 or things like Konqueror don't work right.

( I installed an outside copy of 1.5 and java applets stopped working ).

I need 1.5 to run azureus ( bittorrent client ).

You need to build your own RPM from the jpackage.org wrapper and the Sun binaries:
- download (but don't install) the Sun JDK binary (not the JRE)
- download java-1.5.0-sun-1.5.0.03-1jpp.nosrc.rpm from http://jpackage.org/rpm.php?id=2546
- follow the instructions at http://jpackage.org/rebuilding.php to set up your system with the above files and build your own RPMs
- the rpms will include both a "java" and a "java-devel" rpm - if you just want a JRE not a JDK, don't install the "java-devel" package.

Sadly, this convoluted process is necessary because the JPackage.org people don't think they are legally able to distribute a JRE due to Sun's licensing rules. I'm not quite sure why these rules apply to jpackage.org but not to Suse, I'd guess it's because Suse has more clout :)

Note that if you want to run both Java 1.4 and Java 1.5 you'll need the update-alternatives package - it's included in Suse 9.3 but I'm not sure if it is for 9.2, or if you need to get it from jpackage.org. Using this is beyond the scope of this e-mail :)

- Korny
--
Kornelis Sietsma

< Previous Next >
Follow Ups
References