Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Xmms doesn't work (it can't find alsa??)
  • From: Xaos Katawin <katawin@xxxxxxxxxxx>
  • Date: Wed, 25 May 2005 15:45:37 +0300
  • Message-id: <20050525124537.GA5065@xxxxxxxxxxxxxx>
Hi all

I'm using SuSE 9.2 on a PII. I can't get xmms to work for me. In
fact the ONLY media player that works is kaffeine.

I am trying to play cd's and mp3's. Kaffeine works just fine. On
older versions of SuSE I never had too much trouble with xmms. When
I run xmms, it starts, loads the cd TOC, I select the track but when
I try to play it I get a dialog that says:

Please Check that:
Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the sound card

Of course the card does work since I can hear music with Kaffeine.

In the terminal I use to start xmms I do see the following:

GLib-CRITICAL **: file gutils.c: line 237 (g_basename): assertion
`file_name != NULL' failed.

Not being a programmer, I have no idea what this means.

Then when I push play on xmms I see another message on the terminal:

** WARNING **: alsa_get_mixer(): Attaching to mixer hw:0 failed: No
such device

** WARNING **: alsa_setup(): Failed to open pcm device (default): No
such device

Now according to yast, I have alsa installed so I can't understand
why xmms can't find the devices it mentions. I tried to google the
error messages but I couldn't find anything relevent.

Any thoughts???


< Previous Next >