Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Root password corrupt?
  • From: "suse_gasjr4wd@xxxxxxx" <suse_gasjr4wd@xxxxxxx>
  • Date: Sun, 29 May 2005 23:23:37 -0400
  • Message-id: <BEBFFF79.1F763%suse_gasjr4wd@xxxxxxx>
On 5/29/05 1:15 AM, "Anders Johansson" <andjoh@xxxxxxxxxx> wrote:

> On Sunday 29 May 2005 07:01, suse_gasjr4wd@xxxxxxx wrote:
>> On 5/28/05 5:11 PM, "Anders Johansson" <andjoh@xxxxxxxxxx> wrote:
>>> As for the problem, I would ask: is there a y or a z in the password, or
>>> some special characters? A common bug is that the keyboard is set to
>>> German regardless of what is selected during installation.
>>
>> I think that was the answer I was looking for...
>> Yes, there are y's or z's and-or special characters in the password.
>> Is there a work around for this?
>>
>> However, I have been able to log in for the past few months...so this is a
>> sudden thing. Same bug?
>
> Hm, suddenly I'm not so sure I understand the situation.
>
> After I sent the mail I noticed your reply to Ken's mail, where you said you
> couldn't even log in through ssh. Your comment was "nothing", what exactly
> does that mean? Do you mean the password doesn't work, or do you literally
> mean you get nothing, not even a password prompt when you try ssh:ing to the
> machine?
>

I have two users...using the (only) KDE GUI. Both work fine. When I go to
control center, either user tries to make changes that require a su login
(admin or root password), the password doesn't work. It has worked fine for
the past few months. In the past, I did a google for changing the password
didn't find much that I could do (somewhat CLI challenged, but I'm in
therapy) ;)
Anyway, I just did a reinstall... My boot drive isn't the shared drives, so
it isn't that big a deal. The first time I just figured I forgot it or
something. (I really didn't think so, but...) Then the second install, I
made it something easy. That worked for a few months, then the same thing as
now. I did a reinstall. This time I wrote the password down ON the box.
(still simple) this worked for a few months, till now. I don¹t' remember if
I could ssh in via my OSX box with this latest build or not. (but yes, in
the past I could)
In the past, I didn't have a mouse or keyboard connected to it unless
needed, and then I just grabbed what ever brand I had sitting closest.
Now, I use a Iogear 4 port monitor USB-KVM switch. The USB didn't work...so
I am just using the switch box for the monitor only...and have a separate
keyboard (IBM brand, model KB-9910) and Microsoft mouse (basic optical mouse
pn x09-13962) connected now. At first, I thought it was because I was trying
to use a apple keyboard and Logitech mouse. I guess not.

If I try to ssh in now, it tells me the password isn't correct. (same thing
as using the GUI) I can connect fine using samba file sharing with normal
uses. Both normal users have no problems. I haven't got the netatalk
configured right yet...would like to, but would like to figure this out
first. Sharing works fine, I just can't make any admin changes...(guess
that's the good part)

> Have you ever been able to log in through ssh?
>

See above

> How do you log in when you are sitting by the machine? Through the graphical
> login screen?
>

See above

> If you are, then try switching to a text screen by pressing ctrl-alt-F1 and
> try logging in as root there. As far as I know, the german keyboard bug is
> only in graphical mode. If that works you can edit /etc/X11/XF86Config and
> change the XkbLayout from "de" to whatever it should be in your locale
>
> But if my assumptions are wrong then the problem is elsewhere. It would help
> if you explained exactly how you are trying to log in, and exactly how it
> fails ('it doesn't work' isn't good. 'the screen flashes and brings me back
> to the login' or 'I get an error saying user or password is wrong' or
> something equally detailed is better)
>

Not sure if I answered the questions...I think I did.
I have not had a chance to try the other ideas yet...boot from the CD and
change the password that way. (or changing the run level to 1 and doing it
that way) But I would like to know why this is happening! and no, I didn¹t
forget the password. Something is wrong and I hope I am explaining it right.


--
Thanks,
George


"They that would give up essential liberty for temporary safety deserve
neither liberty nor safety."
Benjamin Franklin


< Previous Next >
References