Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Thunderbird segfault in 9.2
  • From: Catimimi <catimimi@xxxxxxxxxxxxxx>
  • Date: Thu, 03 Mar 2005 20:31:09 +0100
  • Message-id: <422765FD.20400@xxxxxxxxxxxxxx>
Jason Joines a écrit :

I've been using Thunderbird as my mail client fince I installed SuSE 9.2 months ago. I installed via YaST which gave me MozillaThunderbird-0.8-5.0, then upgraded to MozillaThunderbird-1.0-0.1 via the SuSE projects RPM. It's been running fine until 2 days ago. Then I shut it down for what was probably the first time in a few weeks. When I tried to fire it up via the KDE menu, it showed up in the task bar for just a few seconds then went away. When I tried running /opt/MozillaThunderbird/bin/ I got "Segmentation fault". Then I tried running /opt/MozillaThunderbird/lib/thunderbird-bin directly and got "/opt/MozillaThunderbird/lib/thunderbird-bin: error while loading shared libraries: cannot open shared object file: No such file or directory" I looked for this file and found it in /opt/MozillaThunderbird/lib/, the same directory thunderbird-bin is in, so I ran ldd on thunderbird-bin and got:

> ldd thunderbird-bin => (0xffffe000) => not found => /opt/gnome/lib/ (0x4002f000) => /opt/gnome/lib/ (0x402f5000) => /opt/gnome/lib/ (0x40364000) => /opt/gnome/lib/ (0x4037f000) => /opt/gnome/lib/ (0x40394000) => /opt/gnome/lib/ (0x40399000) => /opt/gnome/lib/ (0x403a5000) => /opt/gnome/lib/ (0x403d9000) => /opt/gnome/lib/ (0x40413000) => /lib/ (0x40417000) => /opt/gnome/lib/ (0x4041b000) => not found => not found => not found => not found => /lib/tls/ (0x4049b000) => /usr/X11R6/lib/ (0x404ad000) => /lib/tls/ (0x405aa000) => /usr/lib/ (0x405cd000) => /usr/lib/ (0x405fb000) => /lib/ (0x4061a000) => not found => not found => not found => not found => not found => not found => /usr/X11R6/lib/ (0x4062c000) => /usr/X11R6/lib/ (0x40680000) => /usr/X11R6/lib/ (0x40688000) => not found => /usr/lib/ (0x40696000) => /lib/ (0x40753000) => /lib/tls/ (0x4075b000) => /usr/X11R6/lib/ (0x40872000) => /usr/lib/ (0x40885000) => /usr/lib/ (0x408f4000) => /usr/X11R6/lib/ (0x4091e000) => /usr/X11R6/lib/ (0x40922000) => /usr/X11R6/lib/ (0x4092a000) => /usr/X11R6/lib/ (0x40934000) => /opt/gnome/lib/ (0x4093c000)
/lib/ => /lib/ (0x40000000) => /usr/X11R6/lib/ (0x40961000) => /usr/X11R6/lib/ (0x40969000) => /usr/lib/ (0x40982000)

Next I added /opt/MozillaThunderbird/lib to and ran ldconfig. Then ldd on thunderbird-bin yielded:
> ldd thunderbird-bin => (0xffffe000) => /opt/MozillaThunderbird/lib/ (0x4002e000) => /opt/gnome/lib/ (0x4009a000) => /opt/gnome/lib/ (0x40360000) => /opt/gnome/lib/ (0x403cf000) => /opt/gnome/lib/ (0x403ea000) => /opt/gnome/lib/ (0x403ff000) => /opt/gnome/lib/ (0x40404000) => /opt/gnome/lib/ (0x40410000) => /opt/gnome/lib/ (0x40444000) => /opt/gnome/lib/ (0x4047e000) => /lib/ (0x40482000) => /opt/gnome/lib/ (0x40486000) => /opt/MozillaThunderbird/lib/ (0x40505000) => /opt/MozillaThunderbird/lib/ (0x405ac000) => /opt/MozillaThunderbird/lib/ (0x405af000) => /opt/MozillaThunderbird/lib/ (0x405b3000) => /lib/tls/ (0x405df000) => /usr/X11R6/lib/ (0x405f1000) => /lib/tls/ (0x406ed000) => /usr/lib/ (0x40711000) => /usr/lib/ (0x4073f000) => /lib/ (0x4075e000) => /opt/MozillaThunderbird/lib/ (0x4076f000) => /opt/MozillaThunderbird/lib/ (0x4078c000) => /opt/MozillaThunderbird/lib/ (0x407a9000) => /opt/MozillaThunderbird/lib/ (0x40803000) => /opt/MozillaThunderbird/lib/ (0x40860000) => /opt/MozillaThunderbird/lib/ (0x40883000) => /usr/X11R6/lib/ (0x40887000) => /usr/X11R6/lib/ (0x408da000) => /usr/X11R6/lib/ (0x408e2000) => /opt/MozillaThunderbird/lib/ (0x408f1000) => /usr/lib/ (0x4090a000) => /lib/ (0x409c7000) => /lib/tls/ (0x409cf000) => /usr/X11R6/lib/ (0x40ae5000) => /usr/lib/ (0x40af8000) => /usr/lib/ (0x40b68000) => /usr/X11R6/lib/ (0x40b92000) => /usr/X11R6/lib/ (0x40b96000) => /usr/X11R6/lib/ (0x40b9e000) => /usr/X11R6/lib/ (0x40ba7000) => /opt/gnome/lib/ (0x40bb0000)
/lib/ => /lib/ (0x40000000) => /usr/X11R6/lib/ (0x40bd5000) => /usr/X11R6/lib/ (0x40bdd000) => /usr/lib/ (0x40bf5000)

However, running thunderbird-bin after that just yielded "Segmentation fault". I decided I must've updated something via YOU while it was running and broke something that I just hadn't noticed until I restarted. I uninstalled MozillaThunderbird, then installed again from YaST but had the exact same results with MozillaThunderbird-0.8-5.0. Then I ran YOU again and got MozillaThunderbird-0.8-5.5 but still had the exact same results. I again tried upgrading to the projects version, MozillaThunderbird-1.0-0.1, but still have the same problem.

Any ideas?

Jason Joines


I suggest that you have a look to a thread I wrote in the first week of february. I explained esactly the same problem and the solution (!!) I found. Now it works as you can see.

If you don't find, let me know, I'll try to help you.



< Previous Next >
Follow Ups