Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] stupid dependencies
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Sun, 6 Mar 2005 02:41:01 +0100 (CET)
  • Message-id: <Pine.LNX.4.58.0503060235560.8032@xxxxxxxxxxxxxxxx>

The Saturday 2005-03-05 at 17:50 -0500, Ken Schneider wrote:

> Can anyone explain the following:
>
> yast2-firewall is needed by (installed) yast2-http-server-2.9.20-5
> yast2-firewall is needed by (installed) yast2-ntp-client-2.9.10-14
>
> when trying to uninstall yast2-firewall.
>
> I -don't- need a firewall to run on this machine, I have a firewall on
> another machine. Talk about STUPID dependencies. But if I DON'T install
> the firewall packages I can't run the ntp client nor the http-server
> client.

Don't confuse yast2-firewall package with the SuSEfirewall2 package. The
first is a yast module for configurating the firewall, the second is the
firewall itself - or the scripts.

> I don't understand the need for a firewall to be installed to run an ntp
> client or the http-server config program in yast.

I would install a firewall on every single computer inside the safest of
the intranets.

--
Cheers,
Carlos Robinson


< Previous Next >
References