Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
updating software via YaST
  • From: Mike Dewhirst <miked@xxxxxxxxxxxxxxx>
  • Date: Thu, 17 Mar 2005 09:53:59 +1100
  • Message-id: <4238B907.2080802@xxxxxxxxxxxxxxx>
This is not a top-post. It is a new thread which introduces an older problem and copies parts of previous posts in an attempt to clarify the situation so a generous SuSE guru can help me - and perhaps others?

I need to update subversion and apache2 on SuSE 9.1 and after downloading patches YOU doesn't offer the current versions.

My plan A is to buy SuSE 9.3 and hope they are up to date in there. Being in a hurry I don't want to wait for 9.3.

Plan B is to start again somehow. I tried a week or so ago and didn't succeed following Graham Smith's advice (9 March 2005 - Re: [SLE] Make yast repository)

Have a look at this article in the sdb.
Generating YaST Installation Sources
http://portal.suse.com/sdb/en/2004/02/yast_instsrc.html

Any help gratefully received. As mentioned previously I'm new at all this.

This is what I posted back then ...

However, I'm having trouble with genIS_PLAINcache ...

I have downloaded direct from SuSE

from ...

ftp://ftp.suse.org/pub/projects/apache/apache2/9.1-i386/

the following RPMs ...
apache2-2.0.53-4.1.i586.rpm
apache2-devel-2.0.53-4.1.i586.rpm
apache2-doc-2.0.53-4.1.i586.rpm
apache2-example-pages-2.0.53-4.1.i586.rpm
apache2-mod_auth_mysql-2.8.1-1.1.i586.rpm
apache2-mod_perl-2.0.0-1.1.i586.rpm
apache2-mod_python-3.1.3-37.4.i586.rpm
apache2-prefork-2.0.53-4.1.i586.rpm
apache2-worker-2.0.53-4.1.i586.rpm
libapr0-2.0.53-4.1.i586.rpm
neon-0.24.7-4.1.i586.rpm
neon-devel-0.24.7-4.1.i586.rpm
subversion-1.1.3-7.1.i586.rpm
subversion-devel-1.1.3-7.1.i586.rpm
subversion-doc-1.1.3-7.1.i586.rpm
subversion-perl-1.1.3-7.1.i586.rpm
subversion-python-1.1.3-7.1.i586.rpm
subversion-server-1.1.3-7.1.i586.rpm
subversion-tools-1.1.3-7.1.i586.rpm

They are in /root/samba_share/install_kits/suse_9.1_dvd/suse/new-i586
(feel free to constructively criticise my choice of download destination in a separate thread)

I followed the instructions listed at the link below (reproduced here) - except for what I believe is an error ...

cd /srv/www/htdocs/suse/RPMS/
genIS_PLAINcache -f -r .
gzip genIS_PLAINcache

<error? should be gzip IS_PLAINcache>
When I pointed YaST to that directory it barfed and went away with an error message too quick to read.

Thanks for any help

Mike
< Previous Next >
Follow Ups