Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] someone save my ass prob with root passwd
  • From: Matthew <startux@xxxxxxxxxxxxxxxxxxxx>
  • Date: Sat, 19 Mar 2005 01:54:29 -0800
  • Message-id: <423BF6D5.3070806@xxxxxxxxxxxxxxxxxxxx>
Chaitanya Krishna A wrote:

hi all,

i've been experimenting with suse on one of my friends
machines.

at one point i disabled the root passwd by deleting
the x in the /etc/passwd file. after this i logged out
and tried logging in as root. it was logging me in
without me for any passwd. now i wanted to put a new
passwd for root. so i gave the following commands.

$passwd
prompt for new passwd : <new passwd>
prompt to retype : <new passwd>
then it says
'passwd changed'

i expected the new passwd to be operational. to check
i again logged out and tried logging in as root. but
it didn't prompt me for a passwd, but directly logged
me in. i checked the /etc/passwd file, but there was
no x for the root though i gave a new passwd. am
missing something in the process of changing the
passwd.

i situation is very serious coz my friend is really
freaked that the root is not protected. she already
had her machine hacked once. obviously there's hella
lot of pressure on me to get it straight. someone
help.

bye.
chaitanya.


Did you try SuSEconfig and/or Yast(check security settings etc)? Which version of SuSE?

Of course I am not going to ask about why you were experimenting on a friends machine...

Matt

< Previous Next >
References