Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Any Wireless Card which works with Suse 9.1 Personal
  • From: "navdeep virk" <nvirk@xxxxxxx>
  • Date: Tue, 22 Mar 2005 16:40:13 -0500
  • Message-id: <BAY3-F169F52095573E201C566BFAD4E0@xxxxxxx>
Here's the progress I have made

Card Realtek 8180 , Suse 9.1 Personal
I did what you suggested,got the ndiswrapper compiled ,did
modprobe ndiswrapper

the light on the wlan started blinking.

At this point , I have tried all possible iwconfig commands like

iwconfig wlan0 mode Managed
iwconfig wlan0 essid xxxxx
iwconfig wlan0 key xxxxxxxxxxxxxxxxxxxxxxx

etc . but still the when i do iwconfig again

it shows ESSID:Any/Other , just does not update the ESSID to "my_essid"

another interesting point to note is that

iwlist wlan0 scan

shows me the correct essid of my wireless network . somehow the wlan is not able to obtain an IP .I also tried

dhcpcd wlan0

No results ,dmesg shows No IPv6 Routers Present.

Any Pointers forward .

TIA

From: Andrew Brown <seatrout@xxxxxxxxx>
Reply-To: Andrew Brown <seatrout@xxxxxxxxx>
To: Navdeep Virk <nvirk@xxxxxxx>
CC: suse-linux-e@xxxxxxxx
Subject: Re: [SLE] Any Wireless Card which works with Suse 9.1 Personal
Date: Sun, 20 Mar 2005 19:01:21 +0000

I can't say I have installed a dlink card painlessly, but I have done
it. If you search the archives of this group, you will find the story.
I think your problem may be that you don't have the drivers installed.
In that case, ndiswrappers, which is on the Suse CDs, is a program
which will take windows dirvers for wireless cards and make them run
under linux. You have to install it first, and then run YOU to bring
it up to date. After that, it will make a kernel module which you
install with modprobe in the usual way. There are very detailed
instrucitons around the net. I then had to put the modprobe command
into boot.local to ensure that the drivers were relaoaded on every
boot. Other, smarter, people may have other ways.

On Sun, 20 Mar 2005 12:28:15 -0500, Navdeep Virk <nvirk@xxxxxxx> wrote:
> I have tried to make the Realtek 8180 card work and have failed after repeated attempts . I have had problems with insmod -f rtl8180_24x.o ,tried to compile ,was not successful ,I guess due different kernel sources etc..
> Can somebody suggest a Wireless card which install "Plug and Play " on Suse 9.1 Personal .
> Just to elaborate , The realtek card was auto detected on inserting into the pcmcia slot ,but the suse install failed , I tried using Dlink dwl-650+ also ,which is also detected by suse but fails to install it bailing out without leaving any messages in /var/log/messages . May be I am looking at the wrong log file .
>
> If somebody has installed a wireless card painlessly ,I would appreciate a small how to .
>
> I an unrelated question to the subject ,I loaded the kernel sources from a ftp site. How do I build a new kernel now . Any pitfalls if the build fails ?.
>
> TIA
>
>


--
Andrew Brown
What I do: www.darwinwars.com
What I'm up to: www.thewormbook.com/helmintholog/



< Previous Next >
Follow Ups