Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] YOU error ?
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Wed, 23 Mar 2005 21:19:10 +0100 (CET)
  • Message-id: <Pine.LNX.4.58.0503232103500.10344@xxxxxxxxxxxxxxxx>

The Wednesday 2005-03-23 at 07:46 +0100, Erik Jakobsen wrote:

El 2005-03-23 a las 07:46 +0100, Erik Jakobsen escribió:

> > > Patch: konversation-52003
> > >
> >
> > Huh? :-?
> >
> >
> Jepp :-)

Ah. :-)

>
> > > I have tested it with other YOU mirrors, but receive the same information.
> > >
> > > What is the problem ?
> > >
> >
> > I don't see the problem. Could you expand?
> >
> >
> I try it:
>
> Here is a sample from my log when I try to run YOU:
>
> 2005-03-22 21:06:03 <1> lajka3(7510) [packagemanager++]
> PMYouPatchInfo.cc(parsePackages):306 ACCEPTED_FULL
> 2005-03-22 21:06:03 <1> lajka3(7510) [packagemanager++]
> PMYouPatchInfo.cc(parsePackages):306 ACCEPTED_FULL


Hum. I need a crash course in greek, Matrix style...

[...]

Ah. Found it - leaving the greek for another ocassion:


> 2005-03-22 21:06:03 <1> lajka3(7510) [packagemanager++] PMYouPatchInfo.cc(readDir):531 Check signature of '/var/lib/YaST2/you/mnt/i386/update/9.2/patches/konversation-52003'
> 2005-03-22 21:06:03 <1> lajka3(7510) [liby2util++] ExternalProgram.cc(start_program):163 Executing '/usr/bin/gpg' '--homedir ' '/var/lib/YaST2/gnupg' '--no-default-keyring' '--keyring' '/usr/lib/rpm/gnupg/pubring.gpg' '--verify' '/var/lib/YaST2/you/mnt/i386/update/9.2/patches/konversation-52003'

yast is calling an external program, gnupg, to check the signature of the "konversation" patch file.

> 2005-03-22 21:06:03 <1> lajka3(7510) [liby2util++] ExternalProgram.cc(checkStatus):322 pid 7748 exited with status 2
> 2005-03-22 21:06:03 <3> lajka3(7510) [packagemanager] PMYouPatchInfo.cc(readDir):533 Signature check for '/var/lib/YaST2/you/mnt/i386/update/9.2/patches/konversation-52003' failed.

Signature check failed. That is the problem.

Notice that the problem is not with the rpm package, but the patch file.
This is a text file containing information used by YOU to determine
what/how to update.

You can check for yourself, with the command, as root:

gpg --homedir /var/lib/YaST2/gnupg --no-default-keyring \
--keyring /usr/lib/rpm/gnupg/pubring.gpg \
--verify /var/lib/YaST2/you/mnt/i386/update/9.2/patches/konversation-52003

In my 9.1 system I get:

gpg: WARNING: unsafe permissions on homedir "/var/lib/YaST2/gnupg"
gpg: Signature made Fri Feb 11 14:10:28 2005 CET using DSA key ID 9C800ACA
gpg: Good signature from "SuSE Package Signing Key <build@xxxxxxx>"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 79C1 79B2 E1C8 20C1 890F 9994 A84E DAE8 9C80 0ACA


Correct. Your result should be different, and give a clue on how to solve
it. It might be as simple as manually downloaading again that patch file,
who knows. Or perhaps you don't have the keyring.


--
Cheers,
Carlos Robinson

< Previous Next >
Follow Ups