Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Display problem as root and for network logins.
  • From: Chaitanya Krishna A <icymist82@xxxxxxxxx>
  • Date: Fri, 25 Mar 2005 10:54:48 -0800 (PST)
  • Message-id: <20050325185448.6676.qmail@xxxxxxxxxxxxxxxxxxxxxxx>
Hi all,

--- Ken Schneider <suse-list@xxxxxxxxxxxxx> wrote:

> On Fri, 2005-03-25 at 05:39 -0800, Chaitanya Krishna
> A wrote:
> > Hi all,
> >
> > I have finally made the switch to SuSE 9.1 Pro,
> >
> > There are some annoying problems.
> > 1. No one who logs into my machine from the
> network is
> > able to export the display on to their machines. I
> am
> > working in a research group and most of the time
> we
> > need to share resources. So when one logs in to my
> > machine from another computer and tries to run
> > xmgrace(which is 2D plotting application), or any
> > other application that needs a GUI, he's getting
> the
> > following message with the application not
> starting
> > up.
> >
> > "Can't open display
> > Failed initializing GUI, exiting"
>
> Use ssh -X for access to the remote server. No need
> to set the display
> this way.
This also worked fine.

> > 2. The second one is that, when I as 'root' try to
> run
> > any application that needs to run a GUI(the same
> > application runs if I am a normar user), or that
> needs
> > a graphical window to be opened, I am getting the
> > following message without the application not
> starting
> > up.
> >
> > achala:/usr/local/tmp/firefox-installer #
> > ./firefox-installer
> > Xlib: connection to ":0.0" refused by server
> > Xlib: Invalid XDM-AUTHORIZATION-1 key (failed key
> > comparison)
>
> If you used su to become root try sux instead.
It worked. I used su before.

Thanks.
Chaitnaya.



__________________________________
Do you Yahoo!?
Make Yahoo! your home page
http://www.yahoo.com/r/hs

< Previous Next >
References