Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] downgrade rpm
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Thu, 31 Mar 2005 02:25:40 +0200 (CEST)
  • Message-id: <Pine.LNX.4.58.0503310220090.7825@xxxxxxxxxxxxxxxx>

The Wednesday 2005-03-30 at 09:18 -0600, Ryan McCain wrote:

> I need to downgrade from openldap2-client-2.2.24-0.1 to
> openldap2-client-2.2.6-34.i586.rpm. I am doing this because another
> program I am trying to install requires libler.so.199 and
> libldap.so.199. These are the versions that come with the
> openldap2-client I am trying to downgrade to.
>
> When I run the command to downgrade I get the following results:
>
> omf-h0sck11:~ # rpm -U --oldpackage openldap2-client-2.2.6-34.i586.rpm
> error: Failed dependencies:
> liblber-2.2.so.7 is needed by (installed) ldapcpplib-0.0.3-28.1

You can force it with "--nodeps". Whether you don't get worse problems,
will depend.

> ..I think I'm caught in the preverbial chicken and the egg situation.
>
> Any ideas?

Recompile...

--
Cheers,
Carlos Robinson

< Previous Next >
References