Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Recover question - no kernel
  • From: Stephen Boddy <stephen.boddy@xxxxxxxxxxxxxx>
  • Date: Thu, 31 Mar 2005 02:27:35 +0100
  • Message-id: <200503310227.35596.stephen.boddy@xxxxxxxxxxxxxx>
Apologies to Moby for the personal reply, it's late and I pressed the wrong
key when replying.

On Wednesday 30 March 2005 23:30, Moby wrote:
> I have a need to reinstall the kernel on a SuSE 9.2 box using the
> install CDs and booting into rescue mode. The original root partition
> was at /dev/hda4 and the original /boot was /dev/hda2. Both / and /boot
> are resierfs. Kernel source and binary RPMS exist on the original /
> (/dev/hda4) under /home/raw/kernel. Here at the steps I am taking and
> the issue I keep on facing:
>
> 1) Boot off SuSE 9.2 CD1, choose Rescue, login as root.
> 2) cd /mnt. Then mkdir t4. Then mount /dev/hda4 /mnt/t4.
> 3) chroot /mnt/t4.
> 4) mount /dev/hda2 /boot
>
> At this point, my file system is back the way it used to be before I
> destroyed the kernel. Now to install the kernel I have tried using the
> binary rpms as well as compiling the installing from sources. The
> problem is that both steps, installing the binary RPMs or making from
> source, apparently look for information under /sys. In my case, /sys
> goes away at step (3) above. I understand /sys is a "virtual" file
> system. My question is how do I get my kernel back? I would like to
> install a binary RPM instead of compiling and installing my own.
> However, even when installing from the binary RPM, I see complaints
> about being unable to find items under /sys. I think this makes it
> unable to produce a proper initrd, and as a result of which, even though
> the RPM appears to install fine and I see all the proper looking files
> at all the right places, on a reboot the machine complains about waiting
> for /dev/hda4 and then gives up.
>
> It seems that the use of /sys severely hinders a quick recovery, such as
> simply booting as in steps (1) through (4) above and installing the
> binary kernel RPM.
>
> Thanks in advance for any help

Might be stating the bleeding obvious but doesn't mounting sysfs to the
appropriate place before chroot'ing work? i.e.
mount sysfs /mnt/t4/sysfs -type sysfs

Failing that have you tried going into the Install section of the CD's and
choosing to repair the installation? (This is the first question it asks if
it detects a previous install.)
--
Steve Boddy

< Previous Next >
References