Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Help: Suse 9.1 box won't boot!
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Wed, 2 Feb 2005 00:57:42 +0100 (CET)
  • Message-id: <Pine.LNX.4.58.0502020029570.12975@xxxxxxxxxxxxxxxx>

The Saturday 2005-01-29 at 17:31 -0800, Chris Carlen wrote:

> > > And why does it say it's mounted ro when it is really rw?
> >
> > On the contrary, it complains that it is mounted rw, and thus refuses to
> > check it. You mounted it rw your self first thing - see:
> >
> > > Partition /dev/sda2 is mounted with write permissions, cannot check it
> >
> > ______________________________________^^^^^
> >
> > _write_ permissions, ie, RW.
>
> No, that was the ouput from fsck, which correctly says that the /dev/sda2
> partition is mounted RW. What I was complaining about is the fact that the
> startup scripts reported that the partition was mounted RO, so that it could
> be checked. See:
>
> ...
> fsck failed. Please repair manually and reboot. The root filesystem is
> currently mounted read-only. To remount it read-write do:
> bash# mount -n -o remount,rw /
> Attention: Only CONTROL-D will reboot the system in this maintenance mode.
> Shutdown or reboot will not work.
> Give root password for login:

It seemed to me that you had typed mount command, at what I thought was
the "bash# " prompt. My mistake.

>
> This is normally what happens when a root filesystem is inconsistent when
> booting, and so the boot scripts correctly halt the system and request the
> user to manually run fsck, which must be done with the problem partition
> mounted RO. That is what I tried to do, thinking that there really was a
> problem, and that the problem partition was RO.

Yes, that's correct. It is done by '/etc/init.d/boot.rootfsck', which on
success remounts "/" RW. However, now that I think, on every occasion I
had this problem with a reiserfs, I had to reboot from the rescue CD; from
HD it was impossible to fsck.

> But the / was actually mounted RW. *I* did not mount / RW. The *boot
> scripts* did, and then incorrectly reported that it was RO and needed
> checking.

Funny.

Ah.... perhaps... an idea.

On a second phase, it is the job of '/etc/init.d/boot.localfs' to check
the rest of the partitions, and when it runs, "/" is already RW, I think -
yes, it is:

case "$1" in
start)
# rootfs is mounted rw, lvm et al should be up now


Then it runs fsck, and if the error is greater than 3, it does this:

...
echo "fsck failed. Please repair manually and reboot. The root"
echo "file system is currently mounted read-only. To remount it"
echo "read-write do:"
echo
echo " bash# mount -n -o remount,rw /"


That's the message you saw, isn't it? But at that point root is RW, and
that matches what you saw.

This second script is wrong. There are two mistakes: one is to wrongly
report the RO status (because the script is derived from the first one).
The other is misleading you to think that the root filesystem is faulty,
when it is some other partition.

Ah!

I see it clear, it happened to me as well when I deleted a partition and
forgot to remove it from the fstab file. I got the same error as you did.


> No, it was something else. See my other reply.

Yes, I saw it. It matches what I said on my first paragraph:

|> I'd guess there is something wrong in the fstab file. Probably you have
|> listed some partition with the wrong filesystem, or it is no longer
|> there.


> Thanks for your input and interest.

Welcome :-)

--
Cheers,
Carlos Robinson


< Previous Next >
Follow Ups