Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] kicked out of graphical boot mode
  • From: Jeffrey Laramie <suse-linux-e@xxxxxxxxxxxxxx>
  • Date: Sat, 05 Feb 2005 09:07:01 -0500
  • Message-id: <4204D305.5010404@xxxxxxxxxxxxxx>
devosc wrote:

I installed the smartmontools from the 9.1 distro cds, but it prompted
(informed) me to perform a text first prior to enabeling in the run
level editor.. can someone provide the syntax to use... I tried
smartcl -t but it wants to know about a device?

It uses the same device description as other Linux tools: /dev/hda, /dev/hdb, etc. Note that /dev/hda refers to a drive while /dev/hda1 refers to the first partition on that drive. So your command should be: smartctl -a /dev/hda. Another command line tip. Most, but not all, programs will take -h or --help as an option. This usually lists the most common options available. Also man <program name> will usually give you a detailed description of the available options and sometimes some examples of syntax and usage.

Also, if not too much trouble, could some provide a short list of
steps (commands) to perform (regularly) in order to get check /
correct the disks... especially if after having to do a hard reboot...

I did try fsck but it said current drive had write permissions.... ???


The system automatically checks for inconsistent file systems at boot up. I suspect you tried fsck on a partition that was mounted. The drive that contains your OS needs to be checked by booting a rescue disk and running fsck from the command line. Other mounted drives can be unmounted and checked while the system is up. Unlike some other operating systems, Linux file systems don't need to be checked regularly. If you have problems with file corruption or crashes it's caused by another problem and that problem needs to be resolved.

Jeff

< Previous Next >