Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] problems getting MPlayer installed and running
  • From: Michael James <Michael.James@xxxxxxxx>
  • Date: Mon, 7 Feb 2005 14:50:50 +1100
  • Message-id: <200502071450.50917.Michael.James@xxxxxxxx>
On Sun, 6 Feb 2005 08:56 am, Carl E. Hartung wrote:
> Gil Weber wrote:
> <snip>
>
> |>>error: Failed dependencies:
> |>> liblzo.so.1 is needed by MPlayer-1.0pre6a-pm.2
> |>> libmp3lame.so.0 is needed by MPlayer-1.0pre6a-pm.2
> |>> libnspr4.so is needed by mplayerplug-in-2.70-0.pm.3
> |>> libplc4.so is needed by mplayerplug-in-2.70-0.pm.3
> |>> libplds4.so is needed by mplayerplug-in-2.70-0.pm.3
> |>> libxpcom.so is needed by mplayerplug-in-2.70-0.pm.3
> |>>phred:/home/gil/Downloads/MPlayer_9.2 #
> <snip>
> |>>1) Where can I find the 6 files I'm missing?
> <snip>
>
> Hi Gil,
>
> liblzo.so.1 is provided by SuSE package "lzo" (install via YaST/rpm)
> This /isn't/ mentioned on packman's site as a "dependency"
> <prerequisite,> but whenever rpm complains about a missing dependency
> the first place you should look to fill it is your distribution.
>
> libmp3lame.so.0 is provided by packman's lame-3.96.1-pm.1.x86_64.rpm
> This /is/ listed as a dependency on packman's site.

These x86_64 packages broke it for me.
They depend, naturally enough, on 64 bit versions of libc etc.
And, as you'd expect, my 32 bit i686 install doesn't have them.
Why did packman put me onto 64 gauge rails,
and more important, how do I get off them?

michaelj

--
Michael James michael.james@xxxxxxxx
System Administrator voice: 02 6246 5040
CSIRO Bioinformatics Facility fax: 02 6246 5166

< Previous Next >