Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] boot freeze and black screen
  • From: Darryl Gregorash <raven@xxxxxxxxxxxxx>
  • Date: Mon, 07 Feb 2005 11:06:23 -0600
  • Message-id: <4207A00F.7050201@xxxxxxxxxxxxx>
Thies Eggers wrote:

Dear list,

following problem prevents me from using my SuSE 9.1 Pro. :-( Yesterday
everything still worked fine ... no idea why not any longer.

My SuSE boots fine until the stage were the firewall reaches phase 3 of 3. After
this stage the screen goes black and nothings else happens. As far as I
remember should then the nVidia splash screen apprear and KDE start. But
nothings goes anymore.
I tried 'fsck' and 'reiserfsck' from the rescue system to see whether the disks
might be damaged but there seems to be no error on the harddrives.

Any ideas, what I might do? Is it just the graphic driver that doesn't load? If
so what to do to bring it back?


When this happens, can you switch to another tty? (ctrl-alt-Fn) If you can, log in as root on that tty and switch to runlevel 3. If you cannot, then you need to reboot into runlevel 3; type "init 3" (minus the quotes of course) in the boot prompt.

Now you can try to find out all the details of how/why things went wrong -- if you really want. For example, you can try to run startx from the console, or you can examine the boot and system logs. However, the most probable reason is that the video driver is somehow corrupted (did you upgrade the kernel?), so you can just go ahead and recompile and install it. You might want to use SaX2 to check the recompiled driver, or you can just try to reboot normally (perhaps instead you want to boot into runlevel 3 again, and use startx).

If my memory is correct, the only difference between runlevel 3 and 5 is the graphical vs. console login screen. This is why you probably only need to recompile the video driver; if something else was the problem, you shouldn't be able to boot into runlevel 3 either.




< Previous Next >
References